summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-11-21 22:03:58 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-11-21 22:03:58 -0500
commitcfaa73c300106468a37c13bdb0ce16878a32332c (patch)
tree7f43baf77fb3927ef264a1c2929f05cebefdcd3e /games-puzzle/galaxis/galaxis-1.8.ebuild
parentuse epatch to apply patch (diff)
downloadgentoo-cfaa73c300106468a37c13bdb0ce16878a32332c.tar.gz
gentoo-cfaa73c300106468a37c13bdb0ce16878a32332c.tar.bz2
gentoo-cfaa73c300106468a37c13bdb0ce16878a32332c.zip
use epatch to apply patch
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'games-puzzle/galaxis/galaxis-1.8.ebuild')
-rw-r--r--games-puzzle/galaxis/galaxis-1.8.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/games-puzzle/galaxis/galaxis-1.8.ebuild b/games-puzzle/galaxis/galaxis-1.8.ebuild
index 9aeb8cdb89c8..3b044622438b 100644
--- a/games-puzzle/galaxis/galaxis-1.8.ebuild
+++ b/games-puzzle/galaxis/galaxis-1.8.ebuild
@@ -3,7 +3,7 @@
# $Id$
EAPI=5
-inherit games
+inherit eutils games
DESCRIPTION="A UNIX-hosted, curses-based clone of the nifty little Macintosh freeware game Galaxis"
HOMEPAGE="http://www.catb.org/~esr/galaxis/"
@@ -14,10 +14,12 @@ SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 x86"
IUSE=""
-DEPEND=">=sys-libs/ncurses-5.3"
-RDEPEND="${DEPEND}"
+DEPEND=">=sys-libs/ncurses-5.3:0"
+RDEPEND=${DEPEND}
-PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
src_install() {
dogamesbin galaxis