summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-27 16:25:40 -0400
committerMatt Turner <mattst88@gentoo.org>2021-03-27 16:40:21 -0400
commita015e1ed0d0c5527921959ce2944159511edf2b8 (patch)
tree1d32c8bad932a22d7fd603bd3c31b276343b6b84 /games-puzzle/gnome2048
parentgames-puzzle/gnome-tetravex: Version bump to 3.38.2 (diff)
downloadgentoo-a015e1ed0d0c5527921959ce2944159511edf2b8.tar.gz
gentoo-a015e1ed0d0c5527921959ce2944159511edf2b8.tar.bz2
gentoo-a015e1ed0d0c5527921959ce2944159511edf2b8.zip
games-puzzle/gnome2048: Version bump to 3.38.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'games-puzzle/gnome2048')
-rw-r--r--games-puzzle/gnome2048/Manifest1
-rw-r--r--games-puzzle/gnome2048/gnome2048-3.38.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/games-puzzle/gnome2048/Manifest b/games-puzzle/gnome2048/Manifest
index c86c42acad37..ebc68369eb65 100644
--- a/games-puzzle/gnome2048/Manifest
+++ b/games-puzzle/gnome2048/Manifest
@@ -1,2 +1,3 @@
DIST gnome-2048-3.36.0.tar.xz 117764 BLAKE2B cf8f1fab6c218921a1ca1e3d568a0ea3cea9d7e39cb6631c79a82540c2152f09f3b29726a6af03720c84f6973d8f1371d32819bfec077f08b0803184fc1cf256 SHA512 a61907f7d1fb728ded21b61c74cc5d20f56b19ac4a82d4e068c5b5a8bddc6bd69b5aea1e48b08a83a7942482983981171cf9a73421c98f45dd7aa47e3cee3cf0
DIST gnome-2048-3.36.4.tar.xz 121084 BLAKE2B 2dc8ae415d246780781cee624ff54047534e8d7b25681f6b6ae1e5cd6b8b71668f405a6f78c1a53857def9eabd3f80ff4dbaf415f22432b1251dd2373d511a6f SHA512 4b2e564aaf304e8e97e364a02eb8faf3a0169eab7fe73e8d716f03fd0156fe2796dca1332f257f335c1e7574774d2eb7ed0b97c13925d3300598b34c96fcd561
+DIST gnome-2048-3.38.2.tar.xz 126780 BLAKE2B 8d6eeb63927b49db6ff4cd4f0cf4da73233aa4b916bfb94b994e17417814c004bdbeaa913eee43dbb965e0723d0ef20682df62655138620cd0ba0ce42ad8be1c SHA512 9063c31ef2a1126b92b6f52950237ac3878a8cbe4b1304e2c56e4bc7f8b99320f45ad27b3d7be3fb4cd2a1856bd11a171facc98bc917076118b83380668e4df8
diff --git a/games-puzzle/gnome2048/gnome2048-3.38.2.ebuild b/games-puzzle/gnome2048/gnome2048-3.38.2.ebuild
new file mode 100644
index 000000000000..6e94bd1f38df
--- /dev/null
+++ b/games-puzzle/gnome2048/gnome2048-3.38.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME_ORG_MODULE="gnome-2048"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Move the tiles until you obtain the 2048 tile"
+HOMEPAGE="https://wiki.gnome.org/Apps/2048"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.42.0:2
+ >=x11-libs/gtk+-3.24.0:3
+ >=media-libs/clutter-1.12.0:1.0
+ >=media-libs/clutter-gtk-1.6.0:1.0
+ >=dev-libs/libgee-0.14.0:0.8
+ >=dev-libs/libgnome-games-support-1.7.1:1=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}