summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 13:50:59 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:32:46 +0200
commitf56bc630b2ffcdc6c6738d097911d328ce713d60 (patch)
tree6f074837ae64bd760b034574284417e3371997a5 /games-puzzle/gnudoku/gnudoku-0.93-r1.ebuild
parentgames-puzzle/gfifteen: Drop old (diff)
downloadgentoo-f56bc630b2ffcdc6c6738d097911d328ce713d60.tar.gz
gentoo-f56bc630b2ffcdc6c6738d097911d328ce713d60.tar.bz2
gentoo-f56bc630b2ffcdc6c6738d097911d328ce713d60.zip
games-puzzle/gnudoku: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-puzzle/gnudoku/gnudoku-0.93-r1.ebuild')
-rw-r--r--games-puzzle/gnudoku/gnudoku-0.93-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-puzzle/gnudoku/gnudoku-0.93-r1.ebuild b/games-puzzle/gnudoku/gnudoku-0.93-r1.ebuild
new file mode 100644
index 000000000000..bfd07d1a9a25
--- /dev/null
+++ b/games-puzzle/gnudoku/gnudoku-0.93-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop flag-o-matic
+
+MY_PN="GNUDoku"
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="A program for creating and solving Su Doku puzzles"
+HOMEPAGE="http://www.icculus.org/~jcspray/GNUDoku"
+SRC_URI="http://www.icculus.org/~jcspray/GNUDoku/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+
+RDEPEND=">=dev-cpp/gtkmm-2.6:2.4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${P}-gcc43.patch
+ append-cxxflags -std=c++11
+ sed -i \
+ -e "s:\$(CXX):\$(CXX) ${CXXFLAGS} ${LDFLAGS}:" \
+ Makefile \
+ || die "sed failed"
+}
+
+src_install() {
+ dobin GNUDoku
+ newicon GNUDoku.png ${PN}.png
+ make_desktop_entry ${MY_PN} ${MY_PN}
+ dodoc ALGORITHM Changelog README TODO
+}