summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-06-06 14:44:33 -0700
committerMatt Turner <mattst88@gentoo.org>2021-06-06 14:49:18 -0700
commit14720ed367c5a0a46ea610390a59a19ee6ffaeb6 (patch)
tree30661c0971a5de9203339ca4096afda3ff755788 /games-puzzle/hitori/hitori-3.38.2.ebuild
parentx11-terms/gnome-terminal: Version bump to 3.40.2 (diff)
downloadgentoo-14720ed367c5a0a46ea610390a59a19ee6ffaeb6.tar.gz
gentoo-14720ed367c5a0a46ea610390a59a19ee6ffaeb6.tar.bz2
gentoo-14720ed367c5a0a46ea610390a59a19ee6ffaeb6.zip
games-puzzle/hitori: Version bump to 3.38.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'games-puzzle/hitori/hitori-3.38.2.ebuild')
-rw-r--r--games-puzzle/hitori/hitori-3.38.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-puzzle/hitori/hitori-3.38.2.ebuild b/games-puzzle/hitori/hitori-3.38.2.ebuild
new file mode 100644
index 000000000000..dac7645c4182
--- /dev/null
+++ b/games-puzzle/hitori/hitori-3.38.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Logic puzzle game for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Hitori"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+# gtk+-3.22 for build-time optional gtk_show_uri_on_window usage
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.22.0:3
+ >=x11-libs/cairo-1.4
+"
+DEPEND="${RDEPEND}
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}