summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/jools/jools-0.20-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/jools/jools-0.20-r2.ebuild')
-rw-r--r--games-puzzle/jools/jools-0.20-r2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/games-puzzle/jools/jools-0.20-r2.ebuild b/games-puzzle/jools/jools-0.20-r2.ebuild
new file mode 100644
index 000000000000..ce1b2dab8512
--- /dev/null
+++ b/games-puzzle/jools/jools-0.20-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1 games
+
+MUS_P=${PN}-musicpack-1.0
+DESCRIPTION="clone of Bejeweled, a popular pattern-matching game"
+HOMEPAGE="http://pessimization.com/software/jools/"
+SRC_URI="http://pessimization.com/software/jools/${P}.tar.gz
+ http://pessimization.com/software/jools/${MUS_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="dev-python/pygame[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+RDEPEND=${DEPEND}
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S=${WORKDIR}/${P}/jools
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"/music
+ unpack ${MUS_P}.tar.gz
+}
+
+src_prepare() {
+ echo "MEDIAROOT = \"${GAMES_DATADIR}/${PN}\"" > config.py
+ python_fix_shebang .
+}
+
+src_install() {
+ games_make_wrapper ${PN} "${EPYTHON} ./__init__.py" "$(games_get_libdir)"/${PN}
+ insinto "$(games_get_libdir)"/${PN}
+ doins *.py
+ python_optimize "${D}$(games_get_libdir)/${PN}"
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r fonts images music sounds
+
+ newicon images/ruby/0001.png ${PN}.png
+ make_desktop_entry ${PN} Jools
+ dodoc ../{ChangeLog,doc/{POINTS,TODO}}
+ dohtml ../doc/manual.html
+ prepgamesdirs
+}