summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/larry/larry-1-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/larry/larry-1-r1.ebuild')
-rw-r--r--games-puzzle/larry/larry-1-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/games-puzzle/larry/larry-1-r1.ebuild b/games-puzzle/larry/larry-1-r1.ebuild
new file mode 100644
index 000000000000..ba3b9c32ec45
--- /dev/null
+++ b/games-puzzle/larry/larry-1-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils check-reqs gnome2-utils games
+
+DESCRIPTION="Leisure Suit Larry Reloaded"
+HOMEPAGE="https://www.replaygamesinc.com"
+SRC_URI="LarryReloadedLinux.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RESTRICT="bindist fetch splitdebug"
+
+QA_PREBUILT="${GAMES_PREFIX_OPT#/}/${PN}/Larry-Linux
+ ${GAMES_PREFIX_OPT#/}/${PN}/Larry-Linux_Data/Mono/x86/libmono.so"
+CHECKREQS_DISK_VAR="4500M"
+CHECKREQS_DISK_USR="4500M"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+ einfo
+}
+
+src_prepare() {
+ sed \
+ -e "s#@GAMES_DIR@#${GAMES_PREFIX_OPT}/${PN}#" \
+ "${FILESDIR}"/${PN}-wrapper > "${S}"/larry || die
+}
+
+src_install() {
+ newicon -s 128 Larry/Larry-Linux_Data/Resources/UnityPlayer.png ${PN}.png
+ make_desktop_entry ${PN}
+
+ dogamesbin larry
+ # move it, over 4gb
+ dodir "${GAMES_PREFIX_OPT}"/${PN}
+ mv Larry/* "${ED%/}/${GAMES_PREFIX_OPT}"/${PN}/ || die
+
+ fperms +x "${GAMES_PREFIX_OPT}"/${PN}/Larry-Linux
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}