summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-07-30 22:06:47 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-07-30 22:39:43 -0400
commit8e5ef49a919b663b6c1fa74f08c2cbe03168f92c (patch)
tree8802a8ba0c2d4ad570bcc39f7cceb1a143cb1a28 /games-puzzle/lpairs
parentnet-dns/getdns: add 'copytruncate' to logrotate configuration (diff)
downloadgentoo-8e5ef49a919b663b6c1fa74f08c2cbe03168f92c.tar.gz
gentoo-8e5ef49a919b663b6c1fa74f08c2cbe03168f92c.tar.bz2
gentoo-8e5ef49a919b663b6c1fa74f08c2cbe03168f92c.zip
games-puzzle/lpairs: add 1.0.5, finish migration from games.eclass
This package installs to $datadir/games on its own and needed further changes. Also removed inline workaround (fixed in this version). locale workaround also unneeded as it existed for /usr/games. Closes: https://bugs.gentoo.org/805158 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-puzzle/lpairs')
-rw-r--r--games-puzzle/lpairs/Manifest1
-rw-r--r--games-puzzle/lpairs/lpairs-1.0.5.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/games-puzzle/lpairs/Manifest b/games-puzzle/lpairs/Manifest
index c01428ea8a74..d1390e8f5020 100644
--- a/games-puzzle/lpairs/Manifest
+++ b/games-puzzle/lpairs/Manifest
@@ -1 +1,2 @@
DIST lpairs-1.0.4.tar.gz 536625 BLAKE2B f020f50b47290b961d77335d567dd68bc009e0952e7ebd39d39c041fcc5a2d9e97d6827921b862dd3dd59c7bef0f11165356f41eda022d7583ca27f584e4b02b SHA512 637f9782c1c1faee3fe0d02adeeb7ea70704f1b625922e1ba086cd03e9a6cf1d61a082eff4753a2ec8be5fc7041bd029f193adf847a39e773e4eedd9eafb2b97
+DIST lpairs-1.0.5.tar.gz 557997 BLAKE2B 940482bc0b5cd209366d541fc4b936055741a7d3936b0f218c68a3ecf43ed0189bfe87fc52eefd85896cfe0b2ed592b1362581d93941a0fb73965cf4341cba6f SHA512 381c47969446b778c694f484647ab6a6bd41eb996e741a01a63f1b854c30f78c7e9f1043546a3b8649ec6db940cac3b7ae5ba3c23e6c9df2716a93e6f6d37324
diff --git a/games-puzzle/lpairs/lpairs-1.0.5.ebuild b/games-puzzle/lpairs/lpairs-1.0.5.ebuild
new file mode 100644
index 000000000000..2b8156772c9e
--- /dev/null
+++ b/games-puzzle/lpairs/lpairs-1.0.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Classic memory game"
+HOMEPAGE="http://lgames.sourceforge.net/LPairs/"
+SRC_URI="mirror://sourceforge/lgames/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+sound"
+
+RDEPEND="
+ media-libs/libsdl[sound?,video]
+ virtual/libintl"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext"
+
+src_prepare() {
+ default
+
+ sed -i '/^inst_dir=/s|/games||' configure || die
+}
+
+src_configure() {
+ # --enable-sound doesn't enable it, needs to be unspecified
+ econf $(usev !sound --disable-sound)
+}
+
+src_install() {
+ default
+
+ doicon ${PN}.png
+ make_desktop_entry ${PN} LPairs
+}