summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/mindless
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/mindless')
-rw-r--r--games-puzzle/mindless/Manifest2
-rw-r--r--games-puzzle/mindless/metadata.xml8
-rw-r--r--games-puzzle/mindless/mindless-1.6.ebuild55
3 files changed, 65 insertions, 0 deletions
diff --git a/games-puzzle/mindless/Manifest b/games-puzzle/mindless/Manifest
new file mode 100644
index 000000000000..557e571db9e5
--- /dev/null
+++ b/games-puzzle/mindless/Manifest
@@ -0,0 +1,2 @@
+DIST OracleAll_050523.txt 1280717 SHA256 8c0384da067477f216af77ade0ff2680e9315072406c340700c3993d3786e34c SHA512 d2d46e330a697974bc6c69b8616bdd08c959d1b20840468ccb20ca22a105d7cfac01dd0262113804fb84e790cb1f8ad439c1aa3c17927551617ec2f6de5b83e5 WHIRLPOOL edfb8bcaf6923953358b24be12afff981bdb2c2a72c9d86455bf8d121dcdc5c2180959eb2f09eb9e6c30227dc898adeacfb7421e6199bfd2cf22c3118b16726c
+DIST mindless-1.6.tar.gz 85620 SHA256 1f3c413f6ef96ce380392a39151b5761a8c2a67249402bf02fc582f3d7837eff SHA512 bcb47311aebc127e30e10931e489cbbdb80845c6d95008834abab7ecbb7565eb61a38f47e68d24db5ed9da2cb3467fdaccccd05c6eaaca403afaf41cc76a991f WHIRLPOOL efccab674ce10c885be0dfdfc2c2060c85b7ffa691c46a22bd3acab20357cf39a8ee3a0eb8bacda39d51945269ac000d888e2222c3d8a1ce5f06710d334a8bb8
diff --git a/games-puzzle/mindless/metadata.xml b/games-puzzle/mindless/metadata.xml
new file mode 100644
index 000000000000..d9b978565e96
--- /dev/null
+++ b/games-puzzle/mindless/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">mindless</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-puzzle/mindless/mindless-1.6.ebuild b/games-puzzle/mindless/mindless-1.6.ebuild
new file mode 100644
index 000000000000..822da8b532d6
--- /dev/null
+++ b/games-puzzle/mindless/mindless-1.6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit games
+
+ORANAME="OracleAll_050523.txt"
+DESCRIPTION="play collectable/trading card games (Magic: the Gathering and possibly others) against other people"
+HOMEPAGE="http://mindless.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mindless/${P}.tar.gz
+ http://www.wizards.com/dci/oracle/${ORANAME}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+RESTRICT="mirror" # for the card database
+
+RDEPEND="x11-libs/gtk+:2
+ media-fonts/font-schumacher-misc"
+DEPEND="${RDEPEND}
+ gnome-base/librsvg
+ virtual/pkgconfig"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ cp "${DISTDIR}/${ORANAME}" "${WORKDIR}" || die "cp failed"
+ DATAFILE="${GAMES_DATADIR}/${PN}/${ORANAME}"
+}
+
+src_prepare() {
+ sed -i \
+ -e '/^CC=/d' \
+ -e '/^CFLAGS=/d' \
+ Makefile \
+ || die 'sed failed'
+}
+
+src_install() {
+ dogamesbin mindless
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins "${WORKDIR}/${ORANAME}"
+ dodoc CHANGES README TODO
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "The first time you start ${PN} you need to tell it where to find"
+ elog "the text database of cards. This file has been installed at:"
+ elog "${DATAFILE}"
+ echo
+}