summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSobhan Mohammadpour <www.sobhan.mohammadpour@gmail.com>2017-08-20 07:17:26 +0430
committerJames Le Cuirot <chewi@gentoo.org>2017-11-01 20:41:44 +0000
commit929748ec0cc50a36dca9b64fe1a06eca15818fef (patch)
tree48c96084a5502dc9c24fc901dc2436aa04716a5f /games-puzzle/numptyphysics/files
parentsci-mathematics/why3-for-spark: Enable coq tactics (diff)
downloadgentoo-929748ec0cc50a36dca9b64fe1a06eca15818fef.tar.gz
gentoo-929748ec0cc50a36dca9b64fe1a06eca15818fef.tar.bz2
gentoo-929748ec0cc50a36dca9b64fe1a06eca15818fef.zip
games-puzzle/numptyphysics: fix patch
Closes: https://github.com/gentoo/gentoo/pull/5485
Diffstat (limited to 'games-puzzle/numptyphysics/files')
-rw-r--r--games-puzzle/numptyphysics/files/numptyphysics-9999-gentoo.patch52
1 files changed, 16 insertions, 36 deletions
diff --git a/games-puzzle/numptyphysics/files/numptyphysics-9999-gentoo.patch b/games-puzzle/numptyphysics/files/numptyphysics-9999-gentoo.patch
index 22b5798fc5f3..e1276a86eddc 100644
--- a/games-puzzle/numptyphysics/files/numptyphysics-9999-gentoo.patch
+++ b/games-puzzle/numptyphysics/files/numptyphysics-9999-gentoo.patch
@@ -1,18 +1,7 @@
-diff -ru numptyphysics-9999.orig/external/Box2D/Source/Makefile numptyphysics-9999/external/Box2D/Source/Makefile
---- numptyphysics-9999.orig/external/Box2D/Source/Makefile 2015-11-25 22:27:36.155865064 -0500
-+++ numptyphysics-9999/external/Box2D/Source/Makefile 2015-11-25 22:28:12.924578877 -0500
-@@ -6,8 +6,6 @@
- TARGETS += Gen/nds-float/lib/libbox2d.a Gen/nds-fixed/lib/libbox2d.a
- endif
-
--CXXFLAGS= -g -O2
--
- SOURCES = \
- ./Dynamics/b2Body.cpp \
- ./Dynamics/b2Island.cpp \
-diff -ru numptyphysics-9999.orig/external/glaserl/makefile numptyphysics-9999/external/glaserl/makefile
---- numptyphysics-9999.orig/external/glaserl/makefile 2015-11-25 22:27:36.156865029 -0500
-+++ numptyphysics-9999/external/glaserl/makefile 2015-11-25 22:28:12.924578877 -0500
+diff --git a/external/glaserl/makefile b/external/glaserl/makefile
+index 4120459..f49d9e7 100644
+--- a/external/glaserl/makefile
++++ b/external/glaserl/makefile
@@ -1,7 +1,5 @@
TARGET := libglaserl.a
@@ -21,9 +10,10 @@ diff -ru numptyphysics-9999.orig/external/glaserl/makefile numptyphysics-9999/ex
SOURCES := $(wildcard *.c)
OBJECTS := $(SOURCES:.c=.o)
-diff -ru numptyphysics-9999.orig/makefile numptyphysics-9999/makefile
---- numptyphysics-9999.orig/makefile 2015-11-25 22:27:36.167864644 -0500
-+++ numptyphysics-9999/makefile 2015-11-25 22:28:12.925578842 -0500
+diff --git a/makefile b/makefile
+index 0f9a9b6..292b759 100644
+--- a/makefile
++++ b/makefile
@@ -1,7 +1,6 @@
APP := numptyphysics
@@ -32,30 +22,20 @@ diff -ru numptyphysics-9999.orig/makefile numptyphysics-9999/makefile
all: app
-@@ -13,7 +12,7 @@
+@@ -13,7 +12,7 @@ app: $(TARGET)
$(TARGET): $(OBJECTS) $(LOCAL_LIBS)
- $(SILENTMSG) "\tLD\t$@"
+ $(SILENTMSG) "\tLD\t$@\n"
- $(SILENTCMD) $(CXX) -o $@ $^ $(LIBS)
+ $(SILENTCMD) $(CXX) -o $@ $^ $(LDFLAGS) $(LIBS)
clean: $(ADDITIONAL_CLEAN_TARGETS)
- $(SILENTMSG) "\tCLEAN"
-diff -ru numptyphysics-9999.orig/mk/silent.mk numptyphysics-9999/mk/silent.mk
---- numptyphysics-9999.orig/mk/silent.mk 2015-11-25 22:27:36.168864609 -0500
-+++ numptyphysics-9999/mk/silent.mk 2015-11-25 22:28:12.925578842 -0500
-@@ -2,6 +2,6 @@
- SILENTMSG := @true
- SILENTCMD :=
- else
-- SILENTMSG := @echo
-+ SILENTMSG := @echo -e
- SILENTCMD := @
- endif
-diff -ru numptyphysics-9999.orig/src/Os.cpp numptyphysics-9999/src/Os.cpp
---- numptyphysics-9999.orig/src/Os.cpp 2015-11-25 22:27:36.183864084 -0500
-+++ numptyphysics-9999/src/Os.cpp 2015-11-25 22:29:17.177331313 -0500
-@@ -262,5 +262,5 @@
+ $(SILENTMSG) "\tCLEAN\n"
+diff --git a/src/Os.cpp b/src/Os.cpp
+index b5d7fb9..6a0ccf4 100644
+--- a/src/Os.cpp
++++ b/src/Os.cpp
+@@ -262,5 +262,5 @@ Os::globalDataDir()
}
// System-wide installation