summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 15:59:47 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:34:04 +0200
commitbbe1f12e6544756b3867ed775e8c5f30b2e492bf (patch)
treec0522d27adecbfa65bcd87bd1a64d5f39d8edcf2 /games-puzzle/quadra/quadra-1.2.0-r1.ebuild
parentgames-puzzle/pipewalker: Drop old (diff)
downloadgentoo-bbe1f12e6544756b3867ed775e8c5f30b2e492bf.tar.gz
gentoo-bbe1f12e6544756b3867ed775e8c5f30b2e492bf.tar.bz2
gentoo-bbe1f12e6544756b3867ed775e8c5f30b2e492bf.zip
games-puzzle/quadra: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-puzzle/quadra/quadra-1.2.0-r1.ebuild')
-rw-r--r--games-puzzle/quadra/quadra-1.2.0-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-puzzle/quadra/quadra-1.2.0-r1.ebuild b/games-puzzle/quadra/quadra-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..4f77d48dc9ca
--- /dev/null
+++ b/games-puzzle/quadra/quadra-1.2.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="A tetris clone with multiplayer support"
+HOMEPAGE="https://github.com/quadra-game/quadra"
+SRC_URI="https://github.com/${PN}-game/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXxf86vm
+ x11-libs/libXext
+ media-libs/libpng:0=
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ sys-devel/bc
+ x11-proto/xextproto
+"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "/^libgamesdir:=/s:/games:/${PN}:" \
+ -e "/^datagamesdir:=/s:/games:/${PN}:" \
+ config/config.mk.in || die
+ eapply "${FILESDIR}"/${P}-format.patch
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins ${PN}.res
+ doicon images/${PN}.xpm
+ make_desktop_entry ${PN} Quadra
+
+ HTML_DOCS="help/*" einstalldocs
+}