summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-12-19 12:48:05 -0500
committerMatt Turner <mattst88@gentoo.org>2021-12-19 12:48:05 -0500
commit55519b0d0c5fb6071113b51e62a6a8bb56f36ace (patch)
treea2660fdb74a31d584c68eab222522fba7f03bf9b /games-puzzle/swell-foop
parentdev-util/umockdev: Version bump to 0.17.1 (diff)
downloadgentoo-55519b0d0c5fb6071113b51e62a6a8bb56f36ace.tar.gz
gentoo-55519b0d0c5fb6071113b51e62a6a8bb56f36ace.tar.bz2
gentoo-55519b0d0c5fb6071113b51e62a6a8bb56f36ace.zip
games-puzzle/swell-foop: Version bump to 41.0.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'games-puzzle/swell-foop')
-rw-r--r--games-puzzle/swell-foop/Manifest1
-rw-r--r--games-puzzle/swell-foop/swell-foop-41.0.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/games-puzzle/swell-foop/Manifest b/games-puzzle/swell-foop/Manifest
index 7617f9fcddd4..59626ce7d1d9 100644
--- a/games-puzzle/swell-foop/Manifest
+++ b/games-puzzle/swell-foop/Manifest
@@ -1 +1,2 @@
DIST swell-foop-40.1.tar.xz 821744 BLAKE2B 598af5d5bdeab2b6c3aca849e8c0a1f0c9690d14bc859c4c89bdf0577868efd7450f88e0039925e3cb83c60cd9943965382592962dc49fca31dac933099b7321 SHA512 99a90030eec32163f84e238458fca74b8ba19c7b804dc3f65d7f8f50f3d7f45dfd1cf45d383e332cad6c18fdf5d4eb79bf3c7b9f406a02431ed787b23a1c8cb7
+DIST swell-foop-41.0.1.tar.xz 758800 BLAKE2B 5df8870f5be52a4dfec9c012a2496e9b727eb93d01480bedb1c836b8b399f9b42ff36b18c78dad7ca26dd9da6b143229064167423fba3d7630a86d5108e4f3d2 SHA512 b579616cddb77fb3e6d6a8b382fe4b9692a884d62b0907fd551048dbfe28d3f031ac9c8e43e2888ee408a51bccb026109cd9e9ac371b475eaffebb1d9c237c11
diff --git a/games-puzzle/swell-foop/swell-foop-41.0.1.ebuild b/games-puzzle/swell-foop/swell-foop-41.0.1.ebuild
new file mode 100644
index 000000000000..763530ce1aca
--- /dev/null
+++ b/games-puzzle/swell-foop/swell-foop-41.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Clear the screen by removing groups of colored and shaped tiles"
+HOMEPAGE="https://wiki.gnome.org/Apps/Swell%20Foop"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ >=x11-libs/gtk+-3.24:3
+ >=media-libs/clutter-1.14.0:1.0
+ >=media-libs/clutter-gtk-1.5.0:1.0
+ >=dev-libs/libgnome-games-support-1.7.1:1=
+ >=dev-libs/libgee-0.14.0:0.8=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}