summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Lermytte <gentoo@lermytte.be>2021-07-26 23:09:45 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-07-28 17:59:29 -0400
commit2b0e3182b7897511cae59444723299092d5d9c2a (patch)
treec91aeb2b69428d75174f26737d409700248bdf94 /games-puzzle/tanglet
parentx11-misc/slim: remove unused patch (diff)
downloadgentoo-2b0e3182b7897511cae59444723299092d5d9c2a.tar.gz
gentoo-2b0e3182b7897511cae59444723299092d5d9c2a.tar.bz2
gentoo-2b0e3182b7897511cae59444723299092d5d9c2a.zip
games-puzzle/tanglet: bump to 1.6.1.1 fixing build with >=qt*-5.14
Dropping the patch since - the first part does not respect ${EPREFIX} and can be replaced with an environment variable in the ebuild - the other parts are obsolete Closes: https://bugs.gentoo.org/704360 Closes: https://bugs.gentoo.org/804570 Signed-off-by: Christophe Lermytte <gentoo@lermytte.be> Closes: https://github.com/gentoo/gentoo/pull/21800 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-puzzle/tanglet')
-rw-r--r--games-puzzle/tanglet/Manifest1
-rw-r--r--games-puzzle/tanglet/tanglet-1.6.1.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/games-puzzle/tanglet/Manifest b/games-puzzle/tanglet/Manifest
index 69b5a4701bb6..fa19be2e7091 100644
--- a/games-puzzle/tanglet/Manifest
+++ b/games-puzzle/tanglet/Manifest
@@ -1 +1,2 @@
DIST tanglet-1.5.3-src.tar.bz2 8631208 BLAKE2B b7b0b913a1d862f43d4fb215a09aaba379bda95d75d3d2f59b207361efeda6573055f25db9d07d330fe0957ca774679589f87b79d0766ac669709da37d164f5f SHA512 31b7aada8b244969c2581a0879c30ca1a9b9db8e0cff5c802607dd08038af9487ba59db0e64fabb35feade9d5d700a2a1e04a0052d0ff4639c10a42189671267
+DIST tanglet-1.6.1.1-src.tar.bz2 25059666 BLAKE2B df363cf77863d3dcc77dee95aa1e4dcd20d16438f23e38286bbf5362fa9f8b17a28bc03dc480d6eaf44a443f4b7f977022b978a642d93c4f4c766b5cdd868728 SHA512 d65bc14f44ed1fa1ddae8f90c2aa62fb5d14ea964e36d544916856d9b6b93009509d4d8adf17fd4a45555732fb9b656f24661b2eec52a980bdb8f20512a38ff3
diff --git a/games-puzzle/tanglet/tanglet-1.6.1.1.ebuild b/games-puzzle/tanglet/tanglet-1.6.1.1.ebuild
new file mode 100644
index 000000000000..65f7fae82093
--- /dev/null
+++ b/games-puzzle/tanglet/tanglet-1.6.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg
+
+DESCRIPTION="Single player word finding game based on Boggle"
+HOMEPAGE="https://gottcode.org/tanglet/"
+SRC_URI="https://gottcode.org/tanglet/tanglet-1.6.1.1-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}/usr" tanglet.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}