summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Retornaz <gentoo@retornaz.com>2020-04-17 16:15:59 +0200
committerJames Le Cuirot <chewi@gentoo.org>2020-04-28 23:32:44 +0100
commit2d2b07371eeadd8ace277e35d60cfb854b072dc8 (patch)
tree5b33d9344b1df8e98c36266420cb97170b80917d /games-puzzle/world-of-goo-gog
parentgames-puzzle/world-of-goo-hb-1.53: new package (diff)
downloadgentoo-2d2b07371eeadd8ace277e35d60cfb854b072dc8.tar.gz
gentoo-2d2b07371eeadd8ace277e35d60cfb854b072dc8.tar.bz2
gentoo-2d2b07371eeadd8ace277e35d60cfb854b072dc8.zip
games-puzzle/world-of-goo-gog-1.51.29337: new package
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com> Closes: https://github.com/gentoo/gentoo/pull/15388 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-puzzle/world-of-goo-gog')
-rw-r--r--games-puzzle/world-of-goo-gog/Manifest1
-rw-r--r--games-puzzle/world-of-goo-gog/metadata.xml11
-rw-r--r--games-puzzle/world-of-goo-gog/world-of-goo-gog-1.51.29337.ebuild63
3 files changed, 75 insertions, 0 deletions
diff --git a/games-puzzle/world-of-goo-gog/Manifest b/games-puzzle/world-of-goo-gog/Manifest
new file mode 100644
index 000000000000..161254a87688
--- /dev/null
+++ b/games-puzzle/world-of-goo-gog/Manifest
@@ -0,0 +1 @@
+DIST world_of_goo_1_51_29337.sh 181640558 BLAKE2B 9993b1a25d256b3adbf7b9bd7297cddc4af11b8f83b35a9e44704e6a75a68da4212cc726a406cd60f6665852e9fcf76c7c63a44e551df133242c61176652aa9c SHA512 650e3841d282cd919907912343e12d5d8d7aa6f7a58591e1343c6c9f6f00d74dbfe2086202bad92ef16a6023802ec79fdb3848c63ba38e466d743e5582331310
diff --git a/games-puzzle/world-of-goo-gog/metadata.xml b/games-puzzle/world-of-goo-gog/metadata.xml
new file mode 100644
index 000000000000..b010f5d66be9
--- /dev/null
+++ b/games-puzzle/world-of-goo-gog/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="bundled-libs">Use bundled libs</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-puzzle/world-of-goo-gog/world-of-goo-gog-1.51.29337.ebuild b/games-puzzle/world-of-goo-gog/world-of-goo-gog-1.51.29337.ebuild
new file mode 100644
index 000000000000..15ac77073cfd
--- /dev/null
+++ b/games-puzzle/world-of-goo-gog/world-of-goo-gog-1.51.29337.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils # eutils for make_wrapper()
+
+MY_PN="WorldOfGoo"
+
+DESCRIPTION="A puzzle game with a strong emphasis on physics (GOG edition)"
+HOMEPAGE="http://2dboy.com/"
+SRC_URI="world_of_goo_${PV//./_}.sh"
+
+LICENSE="2dboy-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bundled-libs"
+RESTRICT="fetch bindist strip bundled-libs? ( splitdebug )"
+
+DEPEND="app-arch/unzip"
+RDEPEND="!bundled-libs? (
+ media-libs/libsdl2[alsa,sound,opengl,video]
+ media-libs/sdl2-mixer[vorbis]
+ )
+ sys-libs/glibc
+ virtual/opengl
+ virtual/glu
+ >=sys-devel/gcc-3.4
+ !games-puzzle/world-of-goo
+ !games-puzzle/world-of-goo-hb"
+
+dir="/opt/${PN%-*}"
+
+QA_PREBUILT="${dir:1}/${MY_PN}.bin.x86
+ ${dir:1}/${MY_PN}.bin.x86_64"
+
+pkg_nofetch() {
+ elog "Download ${A} from www.gog.com"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_unpack() {
+ unzip -d "${S}" "${DISTDIR}/${A}"
+}
+
+src_install() {
+ exeinto "${dir}"
+ doexe data/noarch/game/${MY_PN}.bin.x86$(usex amd64 _64)
+
+ make_wrapper "${PN%-*}" "${dir}"/${MY_PN}.bin.x86$(usex amd64 _64) \
+ $(use bundled-libs && (printf '"%s" "%s/lib%s"' "${dir}" "${dir}" $(usex amd64 64) || die))
+
+ insinto "${dir}"
+ doins -r data/noarch/game/game
+ use bundled-libs && doins -r data/noarch/game/lib$(usex amd64 64)
+ newicon data/noarch/game/game/gooicon.png ${PN%-*}.png
+
+ make_desktop_entry ${PN%-*} "World of Goo" ${PN%-*}
+
+ dodoc data/noarch/docs/linux-issues.txt
+ docinto html
+ dodoc data/noarch/game/readme.html
+}