summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-07-17 03:14:01 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-07-17 03:58:48 -0400
commitf306ecedbdd430efacf5fe8b3f9b018f24716e3b (patch)
tree54cd6b4ab634e65330a183ccfa7b38589a587bc5 /games-puzzle/xlogical
parentgames-puzzle/xlogical: add 1.0.8, remove alt_gfx, gcc11 fix (diff)
downloadgentoo-f306ecedbdd430efacf5fe8b3f9b018f24716e3b.tar.gz
gentoo-f306ecedbdd430efacf5fe8b3f9b018f24716e3b.tar.bz2
gentoo-f306ecedbdd430efacf5fe8b3f9b018f24716e3b.zip
games-puzzle/xlogical: drop 1.0.7-r1
Broken with gcc11 alongside other issues. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-puzzle/xlogical')
-rw-r--r--games-puzzle/xlogical/Manifest2
-rw-r--r--games-puzzle/xlogical/files/xlogical-1.0.7-gcc41.patch49
-rw-r--r--games-puzzle/xlogical/files/xlogical-1.0.7-gcc43.patch51
-rw-r--r--games-puzzle/xlogical/metadata.xml3
-rw-r--r--games-puzzle/xlogical/xlogical-1.0.7-r1.ebuild79
5 files changed, 0 insertions, 184 deletions
diff --git a/games-puzzle/xlogical/Manifest b/games-puzzle/xlogical/Manifest
index ced2bdce6d05..4ecce72f5254 100644
--- a/games-puzzle/xlogical/Manifest
+++ b/games-puzzle/xlogical/Manifest
@@ -1,4 +1,2 @@
-DIST xlogical-1.0-7.tar.bz2 1853575 BLAKE2B 6f78f92a14313cf65f171b99c28a4377f7685bf73705a91b92fcf370ad1f3555b7aefe99e6004aa32c62cf8b71f2d754d64acadf3bda345cc8cf3e3f91647d02 SHA512 b47aadff91a7d3057fe8657bdda5c16a910f84f6d324bee82f1beba55de7faf6a599231c8d53ed68cc30f9edfe18f57f31dfc9fe06b8e03fa6120905f37c290d
DIST xlogical-1.0-8.tar.bz2 1789699 BLAKE2B 5d33cc7345c43a21bea8e899e36c87ccf57752f8b96aaa52b61a9042f6531adf6944dff9e57684a86a0f759a8e4e24253618fc2c2e3cdd3c70d20a9cb0a27398 SHA512 3cbba38c430b1f2a6786d1d6893249812e75941fd7ab336ca5d111ec526ef61bb7e09d5365dbcaae23f32a336d8ab840c0e343656054d252043c6c7962b39d18
DIST xlogical.png 4477 BLAKE2B 276abddabc3b26c7b9a3322e34079073a517ae1c7477307ff3429739eb3a88f9cc23dc0e3c637cf0a7aed13c9cf5cf12b40cb8858eaa0c67246d5d1bf746dedf SHA512 761953cc61bf1cea1b0d306006b71cabee800c6ea74aae4ed31f2fcf2e5cb9fa672c6c226c5444ab6b0af858a54522dafe0a1eb0351bb0c9f359fa447d0fbfa0
-DIST xlogical_gfx.zip 347801 BLAKE2B b9c2f963e8ddc5af9fcd7adac691a71c6ee12bc3b3164ce243d076f85c36044b4aa523d27c5dd1480388ff97356ddabd3c7f2c4d223aeeff1a8660fc7c595995 SHA512 14322ae1c8fb7f50513ef47e05372c5dc1ec1b658b33c53477e6b05bbee1de0250b21127891f205d16adc386e7ce37c4b834a62794ee105754b97e49eb5d2a42
diff --git a/games-puzzle/xlogical/files/xlogical-1.0.7-gcc41.patch b/games-puzzle/xlogical/files/xlogical-1.0.7-gcc41.patch
deleted file mode 100644
index 5c77527dc598..000000000000
--- a/games-puzzle/xlogical/files/xlogical-1.0.7-gcc41.patch
+++ /dev/null
@@ -1,49 +0,0 @@
---- a/properties.h
-+++ b/properties.h
-@@ -33,9 +33,7 @@
- #include <map>
- #include <string>
-
--#ifdef WIN32
- using namespace std;
--#endif
-
- #include "defs.h"
-
---- a/anim.h
-+++ b/anim.h
-@@ -27,9 +27,7 @@
- // Language Includes
- #include <list>
-
--#ifdef WIN32
- using namespace std;
--#endif
-
- // Application Includes
- #include "graph.h"
---- a/exception.h
-+++ b/exception.h
-@@ -27,10 +27,9 @@
-
- // Language Includes
- #include <string>
-+#include <iostream>
-
--#ifdef WIN32
- using namespace std;
--#endif
-
- #define CatchEx(aEx) catch( CXLException aEx )
- #define ThrowEx(aError) throw CXLException(aError,__FILE__,__LINE__)
---- a/gamelogic.cpp
-+++ b/gamelogic.cpp
-@@ -154,7 +154,7 @@
- levelFile = NULL;
- }
-
-- currentMap = NULL;
-+ currentMap = gameLevels.begin();
-
- playerName = new char[32+1];
- strcpy( playerName, "nobody" );
diff --git a/games-puzzle/xlogical/files/xlogical-1.0.7-gcc43.patch b/games-puzzle/xlogical/files/xlogical-1.0.7-gcc43.patch
deleted file mode 100644
index 594298c93d44..000000000000
--- a/games-puzzle/xlogical/files/xlogical-1.0.7-gcc43.patch
+++ /dev/null
@@ -1,51 +0,0 @@
---- a/gamelogic.cpp
-+++ b/gamelogic.cpp
-@@ -25,6 +25,7 @@
- #include<fstream>
- #include<cstdio>
- #include<cctype>
-+#include <cstdlib>
-
- #ifndef WIN32
- #include<unistd.h>
---- a/levelmap.cpp
-+++ b/levelmap.cpp
-@@ -21,6 +21,7 @@
- ////////////////////////////////////////////////////////////////////////
-
- // Language Includes
-+#include <cstdlib>
- #include <cstdio>
- #include <cctype>
- #include <cstring>
---- a/mapedit.cpp
-+++ b/mapedit.cpp
-@@ -26,6 +26,8 @@
- #include<cstdio>
- #include<list>
- #include<vector>
-+#include <cstdlib>
-+#include <cstring>
-
- #ifndef WIN32
- #include<unistd.h>
---- a/modlist.cpp
-+++ b/modlist.cpp
-@@ -22,6 +22,7 @@
-
- #include <iostream>
- #include <fstream>
-+#include <cstdlib>
-
- #ifdef WIN32
- #include <afxwin.h>
---- a/tile_spinner.cpp
-+++ b/tile_spinner.cpp
-@@ -24,6 +24,7 @@
-
-
- // Application Includes
-+#include <cstdlib>
- #include "audio.h"
- #include "properties.h"
- #include "defs.h"
diff --git a/games-puzzle/xlogical/metadata.xml b/games-puzzle/xlogical/metadata.xml
index e41e6cb4ba59..26079e608bed 100644
--- a/games-puzzle/xlogical/metadata.xml
+++ b/games-puzzle/xlogical/metadata.xml
@@ -5,7 +5,4 @@
<email>games@gentoo.org</email>
<name>Gentoo Games Project</name>
</maintainer>
- <use>
- <flag name="alt_gfx">Use alternate graphics which are closer to the original Amiga version</flag>
- </use>
</pkgmetadata>
diff --git a/games-puzzle/xlogical/xlogical-1.0.7-r1.ebuild b/games-puzzle/xlogical/xlogical-1.0.7-r1.ebuild
deleted file mode 100644
index 835489919edc..000000000000
--- a/games-puzzle/xlogical/xlogical-1.0.7-r1.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools desktop edos2unix
-
-MY_PV=$(ver_rs 2 '-')
-MY_P=${PN}-${MY_PV}
-DESCRIPTION="SDL logical clone"
-HOMEPAGE="https://changeling.ixionstudios.com/xlogical/"
-SRC_URI="https://changeling.ixionstudios.com/xlogical/downloads/${MY_P}.tar.bz2
- alt_gfx? ( https://changeling.ixionstudios.com/xlogical/downloads/${PN}_gfx.zip )"
-S="${WORKDIR}"/${PN}-$(ver_cut 1-2)
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="alt_gfx"
-
-DEPEND="
- media-libs/libsdl[sound,video]
- media-libs/sdl-image[jpeg]
- media-libs/sdl-mixer[mod]
-"
-RDEPEND="
- ${DEPEND}
- acct-group/gamestat
-"
-BDEPEND="alt_gfx? ( app-arch/unzip )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-gcc41.patch
- "${FILESDIR}"/${P}-gcc43.patch
-)
-
-src_unpack() {
- unpack ${MY_P}.tar.bz2
-
- if use alt_gfx ; then
- cd "${S}"/images || die
- unpack xlogical_gfx.zip
- fi
-}
-
-src_prepare() {
- sed -i '/^CXXFLAGS/d' Makefile.am || die
-
- edos2unix properties.h anim.h exception.h
-
- default
-
- mv configure.in configure.ac || die
- eautoreconf
-}
-
-src_configure() {
- # localstatedir is only used for the score file
- # NOTE: Check on bumps!
- econf --localstatedir="/var/games"
-}
-
-src_install() {
- dobin ${PN}
-
- insinto /usr/share/${PN}
- doins -r ${PN}.{properties,levels} music sound images
- find "${ED}" -name "Makefile*" -exec rm -f '{}' + || die
-
- insinto /var/games/${PN}
- doins ${PN}.scores
-
- fowners root:gamestat /var/games/${PN}/${PN}.scores
- fperms 660 /var/games/${PN}/${PN}.scores
- fperms g+s /usr/bin/${PN}
-
- dodoc AUTHORS ChangeLog NEWS README TODO
- make_desktop_entry ${PN} "Xlogical"
-}