summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/xwelltris
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/xwelltris')
-rw-r--r--games-puzzle/xwelltris/Manifest1
-rw-r--r--games-puzzle/xwelltris/metadata.xml5
-rw-r--r--games-puzzle/xwelltris/xwelltris-1.0.1.ebuild46
3 files changed, 52 insertions, 0 deletions
diff --git a/games-puzzle/xwelltris/Manifest b/games-puzzle/xwelltris/Manifest
new file mode 100644
index 000000000000..f70a9e3b90b4
--- /dev/null
+++ b/games-puzzle/xwelltris/Manifest
@@ -0,0 +1 @@
+DIST xwelltris-1.0.1.src.tar.gz 422822 SHA256 c7b6321a9a6e735d4e57ec350adc7a6eabf76b8e9fb9d4cf9d91243da2adb38b SHA512 6b1080c6e6d1b579c441d1f42bb6454dafed62a63790d5798e83cf137db7ff2ddc07db7e89b34402a5249770697cc3f8ad5e6222266142c7b43f6936828f2536 WHIRLPOOL 88e968bcafb8742e17d61532d564a9497cdfc5fc1ade1baa6015ef0c0a19f73cb4c281f03f355e34640033f9e45e142f37103316fcc16bbbf85bf02ab7722b2a
diff --git a/games-puzzle/xwelltris/metadata.xml b/games-puzzle/xwelltris/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/xwelltris/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild b/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
new file mode 100644
index 000000000000..b00b12951d05
--- /dev/null
+++ b/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit games
+
+DESCRIPTION="2.5D tetris like game"
+HOMEPAGE="http://xnc.jinr.ru/xwelltris/"
+SRC_URI="http://xnc.jinr.ru/xwelltris/src/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]
+ media-libs/sdl-image[gif]"
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL_PROGRAM/s/-s //' \
+ src/Make.common.in || die
+ sed -i \
+ -e "/GLOBAL_SEARCH/s:\".*\":\"${GAMES_DATADIR}/${PN}\":" \
+ src/include/globals.h.in || die
+}
+
+src_configure() {
+ # configure/build process is pretty messed up
+ egamesconf --with-sdl
+}
+
+src_compile() {
+ emake -C src
+}
+
+src_install() {
+ dodir "${GAMES_BINDIR}" "${GAMES_DATADIR}/${PN}" /usr/share/man
+ emake install \
+ INSTDIR="${D}/${GAMES_BINDIR}" \
+ INSTLIB="${D}/${GAMES_DATADIR}/${PN}" \
+ INSTMAN=/usr/share/man
+ dodoc AUTHORS Changelog README*
+ prepgamesdirs
+}