summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-09-24 12:03:00 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2015-09-24 12:03:00 -0400
commit247179202716872cf748e474bb1286de12f27788 (patch)
tree64519636a8b9830708985800c68a4b64b3e9789e /games-puzzle
parentkde4-base.eclass: relax blocker (diff)
downloadgentoo-247179202716872cf748e474bb1286de12f27788.tar.gz
gentoo-247179202716872cf748e474bb1286de12f27788.tar.bz2
gentoo-247179202716872cf748e474bb1286de12f27788.zip
add use deps for libsdl; tidy
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/fbg/fbg-0.9-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/games-puzzle/fbg/fbg-0.9-r1.ebuild b/games-puzzle/fbg/fbg-0.9-r1.ebuild
index d409745878c4..47b2a2af1dbd 100644
--- a/games-puzzle/fbg/fbg-0.9-r1.ebuild
+++ b/games-puzzle/fbg/fbg-0.9-r1.ebuild
@@ -1,6 +1,7 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
+
EAPI=5
inherit eutils games
@@ -16,17 +17,16 @@ IUSE=""
DEPEND="virtual/opengl
virtual/glu
dev-games/physfs
- media-libs/libsdl
+ media-libs/libsdl[opengl,video]
media-libs/libmikmod
x11-libs/libXt"
-RDEPEND="${DEPEND}"
+RDEPEND=${DEPEND}
src_prepare() {
sed -i \
-e "/FBGDATADIR=/s:\".*\":\"${GAMES_DATADIR}/${PN}\":" \
-e '/^datadir=/d' \
- configure \
- || die "sed failed"
+ configure || die
}
src_configure() {