summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-06-19 16:15:33 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-06-19 22:44:14 -0400
commit4e584308bedf48a2f30b2a74d161fad21e726e77 (patch)
tree0e4e05d523a4fb0f7321fb591f456448467211f9 /games-puzzle
parentdev-python/adblock: adjust style (diff)
downloadgentoo-4e584308bedf48a2f30b2a74d161fad21e726e77.tar.gz
gentoo-4e584308bedf48a2f30b2a74d161fad21e726e77.tar.bz2
gentoo-4e584308bedf48a2f30b2a74d161fad21e726e77.zip
games-puzzle/syzygy: modernize cargo.eclass usage
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/syzygy/syzygy-1.0.2.ebuild87
1 files changed, 45 insertions, 42 deletions
diff --git a/games-puzzle/syzygy/syzygy-1.0.2.ebuild b/games-puzzle/syzygy/syzygy-1.0.2.ebuild
index 86262b7a99cf..c4b802feffd0 100644
--- a/games-puzzle/syzygy/syzygy-1.0.2.ebuild
+++ b/games-puzzle/syzygy/syzygy-1.0.2.ebuild
@@ -1,56 +1,59 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
CRATES="
- adler32-1.2.0
- app_dirs-1.2.1
- autocfg-1.0.1
- bitflags-1.2.1
- byteorder-1.3.4
- cc-1.0.66
- cfg-if-1.0.0
- deflate-0.7.20
- fuchsia-cprng-0.1.1
- getopts-0.2.21
- glob-0.2.11
- ico-0.1.0
- inflate-0.3.4
- lazy_static-1.4.0
- libc-0.2.126
- num-integer-0.1.44
- num-iter-0.1.42
- num-traits-0.2.14
- ole32-sys-0.2.0
- png-0.11.0
- rand-0.4.6
- rand_core-0.3.1
- rand_core-0.4.2
- rdrand-0.4.0
- sdl2-0.35.2
- sdl2-sys-0.35.2
- serde-1.0.118
- shell32-sys-0.1.2
- toml-0.5.9
- unicode-width-0.1.8
- version-compare-0.1.0
- winapi-0.2.8
- winapi-0.3.9
- winapi-build-0.1.1
- winapi-i686-pc-windows-gnu-0.4.0
- winapi-x86_64-pc-windows-gnu-0.4.0
- winres-0.1.12
- xdg-2.2.0"
+ adler32@1.2.0
+ app_dirs@1.2.1
+ autocfg@1.0.1
+ bitflags@1.2.1
+ byteorder@1.3.4
+ cc@1.0.66
+ cfg-if@1.0.0
+ deflate@0.7.20
+ fuchsia-cprng@0.1.1
+ getopts@0.2.21
+ glob@0.2.11
+ ico@0.1.0
+ inflate@0.3.4
+ lazy_static@1.4.0
+ libc@0.2.126
+ num-integer@0.1.44
+ num-iter@0.1.42
+ num-traits@0.2.14
+ ole32-sys@0.2.0
+ png@0.11.0
+ rand@0.4.6
+ rand_core@0.3.1
+ rand_core@0.4.2
+ rdrand@0.4.0
+ sdl2-sys@0.35.2
+ sdl2@0.35.2
+ serde@1.0.118
+ shell32-sys@0.1.2
+ toml@0.5.9
+ unicode-width@0.1.8
+ version-compare@0.1.0
+ winapi-build@0.1.1
+ winapi-i686-pc-windows-gnu@0.4.0
+ winapi-x86_64-pc-windows-gnu@0.4.0
+ winapi@0.2.8
+ winapi@0.3.9
+ winres@0.1.12
+ xdg@2.2.0"
inherit cargo desktop xdg
DESCRIPTION="Narrative meta-puzzle game"
HOMEPAGE="https://mdsteele.games/syzygy/"
SRC_URI="
- https://github.com/mdsteele/syzygy/archive/v${PV}.tar.gz -> ${P}.tar.gz
- $(cargo_crate_uris)"
+ https://github.com/mdsteele/syzygy/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ ${CARGO_CRATE_URIS}"
-LICENSE="BSD GPL-3+ ISC MIT ZLIB"
+LICENSE="GPL-3+"
+LICENSE+=" ISC MIT ZLIB" # crates
+LICENSE+=" BSD" # non-automated extra
SLOT="0"
KEYWORDS="~amd64"