summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-02-18 21:30:15 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-18 21:37:40 +0100
commitbc9e094930d5ffb2fdc8f722848ca9227409159b (patch)
tree999310597b4e5967454aae2492a41796940583d8 /games-puzzle
parentx11-plugins/thinkhdaps: Port to python-single-r1 (diff)
downloadgentoo-bc9e094930d5ffb2fdc8f722848ca9227409159b.tar.gz
gentoo-bc9e094930d5ffb2fdc8f722848ca9227409159b.tar.bz2
gentoo-bc9e094930d5ffb2fdc8f722848ca9227409159b.zip
games-puzzle/kiki: Port to python-single-r1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/kiki/files/kiki-1.0.2-build.patch8
-rw-r--r--games-puzzle/kiki/files/kiki-1.0.2-freeglut.patch4
-rw-r--r--games-puzzle/kiki/files/kiki-1.0.2-gcc41.patch4
-rw-r--r--games-puzzle/kiki/kiki-1.0.2-r3.ebuild77
4 files changed, 85 insertions, 8 deletions
diff --git a/games-puzzle/kiki/files/kiki-1.0.2-build.patch b/games-puzzle/kiki/files/kiki-1.0.2-build.patch
index b3798678f81a..7510843272b3 100644
--- a/games-puzzle/kiki/files/kiki-1.0.2-build.patch
+++ b/games-puzzle/kiki/files/kiki-1.0.2-build.patch
@@ -1,5 +1,5 @@
---- kodilib/linux/Makefile
-+++ kodilib/linux/Makefile
+--- a/kodilib/linux/Makefile
++++ b/kodilib/linux/Makefile
@@ -21,7 +21,7 @@
INCLUDES = $(KODI_INCLUDES) $(X11_INCLUDES) $(SDL_INCLUDES)
@@ -9,8 +9,8 @@
src = \
$(KODISRCDIR)/handler/KEventHandler.cpp \
---- linux/Makefile
-+++ linux/Makefile
+--- a/linux/Makefile
++++ b/linux/Makefile
@@ -14,11 +14,7 @@
GLLIBS = -lglut -lGLU -lGL
diff --git a/games-puzzle/kiki/files/kiki-1.0.2-freeglut.patch b/games-puzzle/kiki/files/kiki-1.0.2-freeglut.patch
index aab70ba69b72..bd40acb5c682 100644
--- a/games-puzzle/kiki/files/kiki-1.0.2-freeglut.patch
+++ b/games-puzzle/kiki/files/kiki-1.0.2-freeglut.patch
@@ -1,5 +1,5 @@
---- src/main/main.cpp.orig 2003-04-11 14:42:29.000000000 +0100
-+++ src/main/main.cpp 2006-07-06 19:37:55.000000000 +0100
+--- a/src/main/main.cpp.orig 2003-04-11 14:42:29.000000000 +0100
++++ b/src/main/main.cpp 2006-07-06 19:37:55.000000000 +0100
@@ -9,6 +9,7 @@
#include <math.h>
diff --git a/games-puzzle/kiki/files/kiki-1.0.2-gcc41.patch b/games-puzzle/kiki/files/kiki-1.0.2-gcc41.patch
index 05bdd3707ec7..1c9dd35aabb6 100644
--- a/games-puzzle/kiki/files/kiki-1.0.2-gcc41.patch
+++ b/games-puzzle/kiki/files/kiki-1.0.2-gcc41.patch
@@ -1,5 +1,5 @@
---- src/main/KikiPythonWidget.h.old 2006-05-07 23:14:09.000000000 +0200
-+++ src/main/KikiPythonWidget.h 2006-05-07 23:17:20.000000000 +0200
+--- a/src/main/KikiPythonWidget.h.old 2006-05-07 23:14:09.000000000 +0200
++++ b/src/main/KikiPythonWidget.h 2006-05-07 23:17:20.000000000 +0200
@@ -9,6 +9,7 @@
#include "KikiPos.h"
#include <KTextField.h>
diff --git a/games-puzzle/kiki/kiki-1.0.2-r3.ebuild b/games-puzzle/kiki/kiki-1.0.2-r3.ebuild
new file mode 100644
index 000000000000..91ce45f135fe
--- /dev/null
+++ b/games-puzzle/kiki/kiki-1.0.2-r3.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 toolchain-funcs
+
+DESCRIPTION="Fun 3D puzzle game using SDL/OpenGL"
+HOMEPAGE="http://kiki.sourceforge.net/"
+SRC_URI="mirror://sourceforge/kiki/${P}-src.tgz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ media-libs/libsdl[opengl]
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ virtual/opengl
+ virtual/glu
+ media-libs/freeglut
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ dev-lang/swig"
+
+S=${WORKDIR}/${PN}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc41.patch
+ "${FILESDIR}"/${P}-freeglut.patch
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-build.patch
+)
+
+src_prepare() {
+ default
+
+ rm -f py/runkiki || die
+
+ # Change the hard-coded data dir for sounds, etc...
+ sed -i \
+ -e "s:kiki_home += /;:kiki_home = /usr/share/${PN}/;:g" \
+ -e "s:KConsole\:\:printf(\"WARNING \:\: environment variable KIKI_HOME not set ...\");::g" \
+ -e "s:KConsole\:\:printf(\" ... assuming resources in current directory\");::g" \
+ src/main/KikiController.cpp || die
+
+ # Bug 139570
+ cd SWIG || die
+ swig -c++ -python -globals kiki -o KikiPy_wrap.cpp KikiPy.i || die
+ cp -f kiki.py ../py || die
+ eapply "${FILESDIR}"/${P}-gcc46.patch
+}
+
+src_compile() {
+ tc-export AR CXX
+
+ emake -C kodilib/linux
+ emake -C linux PYTHON_VERSION="${EPYTHON#python}"
+}
+
+src_install() {
+ dobin linux/kiki
+
+ insinto /usr/share/${PN}
+ doins -r sound
+
+ python_moduleinto ${PN}
+ python_domodule py/.
+
+ dodoc Readme.txt Thanks.txt
+}