summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-06-27 19:21:05 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-07-02 03:34:51 +0200
commitc3890ad4e41444be259b648408a63f19a8c9192f (patch)
treef39917c57068d45ac3ca6c7dc883c8dcfaae6905 /games-puzzle
parentapp-benchmarks/stress-ng: remove unused patch(es) (diff)
downloadgentoo-c3890ad4e41444be259b648408a63f19a8c9192f.tar.gz
gentoo-c3890ad4e41444be259b648408a63f19a8c9192f.tar.bz2
gentoo-c3890ad4e41444be259b648408a63f19a8c9192f.zip
games-puzzle/pipepanic: EAPI8 bump, fix calling cc directly
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/31645 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/pipepanic/pipepanic-0.1.3-r3.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/games-puzzle/pipepanic/pipepanic-0.1.3-r3.ebuild b/games-puzzle/pipepanic/pipepanic-0.1.3-r3.ebuild
index f4ce26581c82..354533d21c0c 100644
--- a/games-puzzle/pipepanic/pipepanic-0.1.3-r3.ebuild
+++ b/games-puzzle/pipepanic/pipepanic-0.1.3-r3.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit desktop
+inherit desktop toolchain-funcs
-DESCRIPTION="A simple pipe connecting game"
+DESCRIPTION="Simple pipe connecting game"
HOMEPAGE="http://www.users.waitrose.com/~thunor/pipepanic/"
SRC_URI="http://www.users.waitrose.com/~thunor/pipepanic/dload/${P}-source.tar.gz"
-S="${WORKDIR}"/${P}-source
+S="${WORKDIR}/${P}-source"
LICENSE="GPL-2+ Free-Art-1.2"
SLOT="0"
@@ -23,8 +23,12 @@ src_prepare() {
# change harcoded data paths to match the install directory
sed -i \
-e "s:/opt/QtPalmtop/share/pipepanic/:/usr/share/${PN}/:" \
- main.h \
- || die "sed failed"
+ main.h || die "sed failed"
+}
+
+src_compile() {
+ tc-export CC
+ default
}
src_install() {