summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-27 15:08:23 +0000
committerSam James <sam@gentoo.org>2021-03-27 15:34:45 +0000
commitc9ec19dafe9a1b6a0cffbab874210ccd6f073022 (patch)
treee350ff85bcd0e28d1f875fea68274b2529761bf5 /games-puzzle
parentgames-puzzle/numptyphysics: add 0.3.5 (diff)
downloadgentoo-c9ec19dafe9a1b6a0cffbab874210ccd6f073022.tar.gz
gentoo-c9ec19dafe9a1b6a0cffbab874210ccd6f073022.tar.bz2
gentoo-c9ec19dafe9a1b6a0cffbab874210ccd6f073022.zip
games-puzzle/numptyphysics: sync live ebuild
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/numptyphysics/numptyphysics-9999.ebuild43
1 files changed, 18 insertions, 25 deletions
diff --git a/games-puzzle/numptyphysics/numptyphysics-9999.ebuild b/games-puzzle/numptyphysics/numptyphysics-9999.ebuild
index 01e05708917e..0fbb92009bfa 100644
--- a/games-puzzle/numptyphysics/numptyphysics-9999.ebuild
+++ b/games-puzzle/numptyphysics/numptyphysics-9999.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils gnome2-utils flag-o-matic git-r3
+EAPI=7
-DESCRIPTION="Crayon Physics-like drawing puzzle game using the same excellent Box2D engine"
-HOMEPAGE="http://thp.io/2015/numptyphysics/"
+inherit flag-o-matic git-r3 gnome2-utils toolchain-funcs
+DESCRIPTION="Crayon Physics-like drawing puzzle game using the same excellent Box2D engine"
+HOMEPAGE="https://thp.io/2015/numptyphysics/"
+EGIT_REPO_URI="https://github.com/thp/numptyphysics"
# This is only the SRC_URI for the user levels. The code is in git repo.
SRC_URI="user-levels? (
http://numptyphysics.garage.maemo.org/levels/butelo/butelo.npz
@@ -32,35 +33,27 @@ SRC_URI="user-levels? (
http://numptyphysics.garage.maemo.org/levels/zeez/zeez.npz
)"
-EGIT_REPO_URI="https://github.com/thp/numptyphysics"
-
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS=""
IUSE="+user-levels"
-RDEPEND="media-libs/libsdl2[opengl,video]
+RDEPEND="
+ dev-libs/glib:2
+ media-libs/libsdl2[opengl,video]
media-libs/sdl2-image[png]
media-libs/sdl2-ttf
virtual/opengl
- dev-libs/glib:2"
-DEPEND="${DEPEND}
- virtual/pkgconfig"
+"
+DEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
-src_unpack() {
- git-r3_src_unpack
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.5-gentoo.patch
+)
-src_prepare() {
- append-cxxflags -std=c++11 -Isrc
- sed -i '/-g -O2/d' external/Box2D/Source/Makefile \
- external/glaserl/makefile || die
- sed -i "/return thp::/s% thp::.*$%\"/usr/share/${PN}/data\";%" \
- src/Os.cpp || die
- sed -e '/CXXFLAGS +=/s/\(CXXFLAGS +=\).*\( -DAPP=.*\)/\1\2/' \
- -e '/SILENTCMD/s/$(LIBS)$/$(LDFLAGS) $(LIBS)/' \
- -i makefile || die
- eapply_user
+src_compile() {
+ tc-export CC CXX
+ emake
}
pkg_preinst() {