summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2020-09-13 00:24:26 +0100
committerJames Le Cuirot <chewi@gentoo.org>2020-09-13 13:58:29 +0100
commitda9edaa41ab976dc18bc2d32e5d1ef11d88d7183 (patch)
tree2f9e132b77ba000a4aaa8e6808843bc46b5024c7 /games-puzzle
parentgames-rpg/freedroidrpg: Drop old 0.16-r1 (diff)
downloadgentoo-da9edaa41ab976dc18bc2d32e5d1ef11d88d7183.tar.gz
gentoo-da9edaa41ab976dc18bc2d32e5d1ef11d88d7183.tar.bz2
gentoo-da9edaa41ab976dc18bc2d32e5d1ef11d88d7183.zip
games-puzzle/atomix: fix build with gcc10
Closes: https://bugs.gentoo.org/707728 Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/17518 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/atomix/atomix-3.34.0-r1.ebuild30
-rw-r--r--games-puzzle/atomix/files/atomix-3.34.0-fnocommon.patch26
2 files changed, 56 insertions, 0 deletions
diff --git a/games-puzzle/atomix/atomix-3.34.0-r1.ebuild b/games-puzzle/atomix/atomix-3.34.0-r1.ebuild
new file mode 100644
index 000000000000..75c5b6489394
--- /dev/null
+++ b/games-puzzle/atomix/atomix-3.34.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson xdg
+
+DESCRIPTION="Mind game - build molecules out of single atoms"
+HOMEPAGE="https://wiki.gnome.org/Apps/Atomix"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=x11-libs/gtk+-3.10:3
+ >=x11-libs/gdk-pixbuf-2.0.5:2
+ >=dev-libs/glib-2.36.0:2
+ dev-libs/libgnome-games-support:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fnocommon.patch"
+)
diff --git a/games-puzzle/atomix/files/atomix-3.34.0-fnocommon.patch b/games-puzzle/atomix/files/atomix-3.34.0-fnocommon.patch
new file mode 100644
index 000000000000..7465fb23a6e2
--- /dev/null
+++ b/games-puzzle/atomix/files/atomix-3.34.0-fnocommon.patch
@@ -0,0 +1,26 @@
+Fixes build with -fno-common
+
+diff -Nurp atomix-3.34.0/src/level.c atomix-3.34.0-fix/src/level.c
+--- atomix-3.34.0/src/level.c 2019-09-09 19:14:36.000000000 -0000
++++ atomix-3.34.0-fix/src/level.c 2020-09-12 23:21:04.917492187 -0000
+@@ -31,7 +31,7 @@ static void level_class_init (GObjectCla
+ static void level_init (Level *level);
+ static void level_finalize (GObject *object);
+
+-GObjectClass *parent_class;
++static GObjectClass *parent_class;
+
+ /*=================================================================
+
+diff -Nurp atomix-3.34.0/src/theme.c atomix-3.34.0-fix/src/theme.c
+--- atomix-3.34.0/src/theme.c 2019-09-09 19:14:36.000000000 -0000
++++ atomix-3.34.0-fix/src/theme.c 2020-09-12 23:21:19.557735891 -0000
+@@ -32,7 +32,7 @@ static void theme_init (Theme *theme);
+ static void theme_finalize (GObject *object);
+ static void destroy_theme_image (gpointer data);
+
+-GObjectClass *parent_class;
++static GObjectClass *parent_class;
+
+ GType theme_get_type (void)
+ {