summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 13:39:04 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:32:34 +0200
commite8e68b680dab16f5348a5f9912d06c94ffbf166c (patch)
tree44498d6ec03d1899b6578a9b766f2d497b62e1e5 /games-puzzle
parentgames-puzzle/flobopuyo: Drop old (diff)
downloadgentoo-e8e68b680dab16f5348a5f9912d06c94ffbf166c.tar.gz
gentoo-e8e68b680dab16f5348a5f9912d06c94ffbf166c.tar.bz2
gentoo-e8e68b680dab16f5348a5f9912d06c94ffbf166c.zip
games-puzzle/freesweep: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/freesweep/freesweep-0.92-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/games-puzzle/freesweep/freesweep-0.92-r1.ebuild b/games-puzzle/freesweep/freesweep-0.92-r1.ebuild
new file mode 100644
index 000000000000..fe5d96ca8f6d
--- /dev/null
+++ b/games-puzzle/freesweep/freesweep-0.92-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Console Minesweeper"
+HOMEPAGE="http://freshmeat.net/projects/freesweep"
+SRC_URI="http://www.upl.cs.wisc.edu/~hartmann/sweep/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-macos"
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses)"
+}
+
+src_install() {
+ dobin freesweep
+ einstalldocs
+ doman freesweep.6
+}