summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 14:12:51 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:33:06 +0200
commitf9b65ce826e53c33aa94f9a86558b912341f7b08 (patch)
treef1fafded28a854d920bd8395a21cd29a3e01c890 /games-puzzle
parentgames-puzzle/hangman: Drop old (diff)
downloadgentoo-f9b65ce826e53c33aa94f9a86558b912341f7b08.tar.gz
gentoo-f9b65ce826e53c33aa94f9a86558b912341f7b08.tar.bz2
gentoo-f9b65ce826e53c33aa94f9a86558b912341f7b08.zip
games-puzzle/hexamine: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/hexamine/hexamine-0.2.1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-puzzle/hexamine/hexamine-0.2.1-r1.ebuild b/games-puzzle/hexamine/hexamine-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..67529d0521a4
--- /dev/null
+++ b/games-puzzle/hexamine/hexamine-0.2.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit desktop python-single-r1
+
+DESCRIPTION="Hexagonal Minesweeper"
+HOMEPAGE="https://sourceforge.net/projects/hexamine"
+SRC_URI="mirror://sourceforge/hexamine/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygame
+"
+DEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ default
+ # Modify game data directory
+ sed -i \
+ -e "s:\`dirname \$0\`:/usr/share/${PN}:" \
+ -e "s:\./hexamine:exec ${EPYTHON} &:" \
+ hexamine || die
+}
+
+src_install() {
+ dobin hexamine
+ insinto "/usr/share/${PN}"
+ doins -r hexamine.* skins
+ einstalldocs
+ make_desktop_entry ${PN} "Hexamine"
+}