summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-02-06 14:51:03 +0000
committerJames Le Cuirot <chewi@gentoo.org>2022-02-06 14:52:21 +0000
commitfca8da51eb3c7c5300bdf6a762317f325217ef19 (patch)
treed241ce19a5ebf185e291c1997c62fbda615b11d5 /games-puzzle
parentprofiles: Mask games-puzzle/braid-* on no-multilib amd64 (diff)
downloadgentoo-fca8da51eb3c7c5300bdf6a762317f325217ef19.tar.gz
gentoo-fca8da51eb3c7c5300bdf6a762317f325217ef19.tar.bz2
gentoo-fca8da51eb3c7c5300bdf6a762317f325217ef19.zip
games-puzzle/braid-hb: New package for the Humble Bundle version
Closes: https://bugs.gentoo.org/349136 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/braid-hb/Manifest1
-rw-r--r--games-puzzle/braid-hb/braid-hb-20150611.ebuild55
-rw-r--r--games-puzzle/braid-hb/metadata.xml8
3 files changed, 64 insertions, 0 deletions
diff --git a/games-puzzle/braid-hb/Manifest b/games-puzzle/braid-hb/Manifest
new file mode 100644
index 000000000000..ddcc6b10c46a
--- /dev/null
+++ b/games-puzzle/braid-hb/Manifest
@@ -0,0 +1 @@
+DIST BraidSetup-2015-06-11.sh 121622129 BLAKE2B 9cb255621c6e2461dff0ca0dc779d62aef09a16d413e1909c505e41be1db5475be5ced8e16ce8d989faa70f3f7a614e3ac7af99a28feccf1859182dca762b042 SHA512 8f27efd0e6514f92c177663d5cb342b026017e66abe2a46df6b08880a28c8220a7cfcb5607eaf01ace3a39c7c8af5e5f9f62c661d4018cdadc102f4caf677a93
diff --git a/games-puzzle/braid-hb/braid-hb-20150611.ebuild b/games-puzzle/braid-hb/braid-hb-20150611.ebuild
new file mode 100644
index 000000000000..a7b6cbc8ee37
--- /dev/null
+++ b/games-puzzle/braid-hb/braid-hb-20150611.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop unpacker wrapper xdg
+
+MY_PN="braid"
+DESCRIPTION="Platform game where you manipulate flow of time"
+HOMEPAGE="https://www.humblebundle.com/store/braid"
+SRC_URI="BraidSetup-${PV:0:4}-${PV:4:2}-${PV:6:2}.sh"
+
+LICENSE="all-rights-reserved Arphic CC-BY-NC-SA-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+BDEPEND="
+ app-arch/unzip
+"
+
+RDEPEND="
+ media-gfx/nvidia-cg-toolkit[abi_x86_32]
+ media-libs/libsdl2[joystick,opengl,sound,video,abi_x86_32]
+ virtual/opengl[abi_x86_32]
+ x11-libs/fltk:1[abi_x86_32]
+ x11-libs/libX11[abi_x86_32]
+ !${CATEGORY}/${MY_PN}-gog
+"
+
+S="${WORKDIR}/data"
+DIR="/opt/${MY_PN}"
+QA_PREBUILT="${DIR#/}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ exeinto "${DIR}"
+ insinto "${DIR}"
+
+ doexe x86/{Braid,launcher}.bin.x86
+ doins -r noarch/{data,Icon.*}
+ dodoc noarch/READ_ME.txt
+
+ make_wrapper ${MY_PN} ./launcher.bin.x86 "${DIR}" /usr/$(ABI=x86 get_libdir)/fltk
+ make_desktop_entry ${MY_PN} Braid "${EPREFIX}${DIR}"/Icon.png
+}
diff --git a/games-puzzle/braid-hb/metadata.xml b/games-puzzle/braid-hb/metadata.xml
new file mode 100644
index 000000000000..7c730d47817a
--- /dev/null
+++ b/games-puzzle/braid-hb/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>