summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-05 17:24:46 +0000
committerSam James <sam@gentoo.org>2021-04-05 17:45:45 +0000
commitd6395f0fdfaa83e86d6765c6879cdc94637d7735 (patch)
tree5ccab2ff0ce47a1c74f370b05a1c5194fabdeb48 /games-roguelike/adom
parentdev-games/quake4-sdk: style changes (diff)
downloadgentoo-d6395f0fdfaa83e86d6765c6879cdc94637d7735.tar.gz
gentoo-d6395f0fdfaa83e86d6765c6879cdc94637d7735.tar.bz2
gentoo-d6395f0fdfaa83e86d6765c6879cdc94637d7735.zip
games-roguelike/adom: add missing inherit, fix games.eclass porting
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-roguelike/adom')
-rw-r--r--games-roguelike/adom/adom-1.1.1-r1.ebuild16
-rw-r--r--games-roguelike/adom/adom-3.3.3.ebuild11
2 files changed, 13 insertions, 14 deletions
diff --git a/games-roguelike/adom/adom-1.1.1-r1.ebuild b/games-roguelike/adom/adom-1.1.1-r1.ebuild
index 46b385a623a8..970d7dfc438a 100644
--- a/games-roguelike/adom/adom-1.1.1-r1.ebuild
+++ b/games-roguelike/adom/adom-1.1.1-r1.ebuild
@@ -1,27 +1,29 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit edos2unix
+
DESCRIPTION="Ancient Domains Of Mystery rogue-like game"
HOMEPAGE="https://www.adom.de/"
SRC_URI="https://www.adom.de/adom/download/linux/${P//.}-elf.tar.gz"
+S="${WORKDIR}"/${PN}
LICENSE="adom"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RESTRICT="strip" #bug #137340
+RESTRICT="strip" # bug #137340
RDEPEND="sys-libs/ncurses-compat:5[abi_x86_32(-)]"
-S=${WORKDIR}/${PN}
-
src_install() {
- exeinto "/opt/bin"
+ exeinto /opt/bin
doexe adom
- keepdir "/var/games/${PN}"
- echo "/var/games/${PN}" > adom_ds.cfg
+ keepdir /var/lib/${PN}
+ echo /var/lib/${PN} > adom_ds.cfg || die
+
insinto /etc
doins adom_ds.cfg
diff --git a/games-roguelike/adom/adom-3.3.3.ebuild b/games-roguelike/adom/adom-3.3.3.ebuild
index b798715acff0..7b977d239f35 100644
--- a/games-roguelike/adom/adom-3.3.3.ebuild
+++ b/games-roguelike/adom/adom-3.3.3.ebuild
@@ -1,28 +1,25 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
MY_P="${PN}_linux_debian"
-S="${WORKDIR}/adom"
DESCRIPTION="Ancient Domains Of Mystery rogue-like game"
HOMEPAGE="https://www.adom.de/"
SRC_URI="x86? ( https://www.adom.de/home/download/current/${MY_P}_32_${PV}.tar.gz -> ${P}_x86.tar.gz )
amd64? ( https://www.adom.de/home/download/current/${MY_P}_64_${PV}.tar.gz -> ${P}_amd64.tar.gz )"
+S="${WORKDIR}"/adom
LICENSE="adom"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RESTRICT="strip" # The executable is pre-stripped
-DOCS=( "docs/adomfaq.txt"
- "docs/credits.txt"
- "docs/manual.txt"
- "docs/readme1st.txt" )
+DOCS=( "docs/adomfaq.txt" "docs/credits.txt" "docs/manual.txt" "docs/readme1st.txt" )
src_install() {
- exeinto "/opt/bin"
+ exeinto /opt/bin
doexe adom
einstalldocs