summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-08-05 16:11:42 -0500
committerAustin English <wizardedit@gentoo.org>2016-08-05 16:31:13 -0500
commit2d95c6c2afa5633823c066850be3aed5a3cf638e (patch)
tree3c0490bb2419c12d47cad420d7acc9e7911fa673 /games-roguelike/crossfire-client
parentgames-roguelike/angband: remove deprecated games eclass (diff)
downloadgentoo-2d95c6c2afa5633823c066850be3aed5a3cf638e.tar.gz
gentoo-2d95c6c2afa5633823c066850be3aed5a3cf638e.tar.bz2
gentoo-2d95c6c2afa5633823c066850be3aed5a3cf638e.zip
games-roguelike/crossfire-client: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-roguelike/crossfire-client')
-rw-r--r--games-roguelike/crossfire-client/crossfire-client-1.71.0-r2.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/games-roguelike/crossfire-client/crossfire-client-1.71.0-r2.ebuild b/games-roguelike/crossfire-client/crossfire-client-1.71.0-r2.ebuild
new file mode 100644
index 000000000000..4c89fc911f58
--- /dev/null
+++ b/games-roguelike/crossfire-client/crossfire-client-1.71.0-r2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools toolchain-funcs gnome2-utils
+
+DESCRIPTION="Client for the nethack-style but more in the line of UO"
+HOMEPAGE="http://crossfire.real-time.com/"
+SRC_URI="mirror://sourceforge/crossfire/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="lua opengl sdl sound"
+
+RDEPEND="
+ lua? ( dev-lang/lua:0= )
+ media-libs/libpng:0
+ net-misc/curl
+ opengl? ( virtual/opengl
+ media-libs/freeglut )
+ sdl? ( media-libs/libsdl[video]
+ media-libs/sdl-image[png] )
+ sound? ( media-libs/sdl-mixer[vorbis] )
+ sys-libs/zlib
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -ri -e '/^.TH/s:$: 6:' $(find . -name "*man") || die
+ sed -i -e 's/lua-5.1/lua/' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ # bugs in configure script so we cant use $(use_enable ...)
+ local myconf
+
+ use lua && myconf="${myconf} --enable-lua"
+ use sdl || myconf="${myconf} --disable-sdl"
+ use opengl || myconf="${myconf} --disable-opengl"
+ use sound || myconf="${myconf} --disable-sound"
+
+ econf ${myconf}
+}
+
+src_compile() {
+ # bug 139785
+ if use sound ; then
+ emake -C sound-src AR="$(tc-getAR)"
+ fi
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ local s
+
+ default
+ domenu gtk-v2/crossfire-client.desktop
+ for s in 16 32 48
+ do
+ newicon -s ${s} pixmaps/${s}x${s}.png ${PN}.png
+ done
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}