summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-11-06 02:23:27 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-11-06 02:23:56 -0500
commit6fe7401f7bb16e44528581621da38a989b3a1a17 (patch)
tree8dc98ffe0cd28ce6afcca57d1f3abc7f78959294 /games-roguelike/crossfire-client
parentapp-admin/ulogd: Merge "add maintainer's name to metadata" (diff)
downloadgentoo-6fe7401f7bb16e44528581621da38a989b3a1a17.tar.gz
gentoo-6fe7401f7bb16e44528581621da38a989b3a1a17.tar.bz2
gentoo-6fe7401f7bb16e44528581621da38a989b3a1a17.zip
fix sound and lua config options; dep fixups
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'games-roguelike/crossfire-client')
-rw-r--r--games-roguelike/crossfire-client/crossfire-client-1.71.0-r1.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/games-roguelike/crossfire-client/crossfire-client-1.71.0-r1.ebuild b/games-roguelike/crossfire-client/crossfire-client-1.71.0-r1.ebuild
new file mode 100644
index 000000000000..0a17233cc41e
--- /dev/null
+++ b/games-roguelike/crossfire-client/crossfire-client-1.71.0-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools toolchain-funcs gnome2-utils games
+
+DESCRIPTION="Client for the nethack-style but more in the line of UO"
+HOMEPAGE="http://crossfire.real-time.com/"
+SRC_URI="mirror://sourceforge/crossfire/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="lua opengl sdl sound"
+
+RDEPEND="
+ sound? ( media-libs/sdl-mixer[vorbis] )
+ opengl? ( virtual/opengl
+ media-libs/freeglut )
+ sdl? ( media-libs/libsdl[video]
+ media-libs/sdl-image[png] )
+ lua? ( dev-lang/lua:0= )
+ x11-libs/gtk+:2
+ net-misc/curl
+ media-libs/libpng:0
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -ri -e '/^.TH/s:$: 6:' $(find . -name "*man") || die
+ sed -i -e 's/lua-5.1/lua/' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ # bugs in configure script so we cant use $(use_enable ...)
+ local myconf
+
+ use lua && myconf="${myconf} --enable-lua"
+ use sdl || myconf="${myconf} --disable-sdl"
+ use opengl || myconf="${myconf} --disable-opengl"
+ use sound || myconf="${myconf} --disable-sound"
+
+ egamesconf ${myconf}
+}
+
+src_compile() {
+ # bug 139785
+ if use sound ; then
+ emake -C sound-src AR="$(tc-getAR)"
+ fi
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ local s
+
+ default
+ domenu gtk-v2/crossfire-client.desktop
+ for s in 16 32 48
+ do
+ newicon -s ${s} pixmaps/${s}x${s}.png ${PN}.png
+ done
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}