summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfgang E. Sanyer <ezzieyguywuf@gmail.com>2021-03-08 22:18:57 -0500
committerSam James <sam@gentoo.org>2021-04-05 17:45:49 +0000
commit104ca58ef4e5af8d7978dd78327c102e32d9c4c3 (patch)
treea758f4ec013f54fbb393f85a5a8cc9f026f6a69c /games-roguelike
parentgames-roguelike/tome: fix games.eclass porting, pkgconfig calls, multilib-- (diff)
downloadgentoo-104ca58ef4e5af8d7978dd78327c102e32d9c4c3.tar.gz
gentoo-104ca58ef4e5af8d7978dd78327c102e32d9c4c3.tar.bz2
gentoo-104ca58ef4e5af8d7978dd78327c102e32d9c4c3.zip
games-roguelike/zangband: remove games.eclass, update to EAPI 7
TODO: figure out why DESTDIR is not respected Signed-off-by: Wolfgang E. Sanyer <ezzieyguywuf@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/zangband/zangband-2.7.4c.ebuild52
1 files changed, 27 insertions, 25 deletions
diff --git a/games-roguelike/zangband/zangband-2.7.4c.ebuild b/games-roguelike/zangband/zangband-2.7.4c.ebuild
index 23fcdc425c07..39b08af052a5 100644
--- a/games-roguelike/zangband/zangband-2.7.4c.ebuild
+++ b/games-roguelike/zangband/zangband-2.7.4c.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit autotools eutils games
+inherit autotools multilib
DESCRIPTION="An enhanced version of the Roguelike game Angband"
HOMEPAGE="http://www.zangband.org/"
@@ -25,39 +25,41 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}
+PATCHES=( "${FILESDIR}"/${P}-tk85.patch
+ "${FILESDIR}"/${P}-rng.patch
+ "${FILESDIR}"/${P}-tinfo.patch
+ "${FILESDIR}"/${P}-configure.patch
+ "${FILESDIR}"/${P}-makefile.patch )
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-tk85.patch \
- "${FILESDIR}"/${P}-rng.patch \
- "${FILESDIR}"/${P}-tinfo.patch \
- "${FILESDIR}"/${P}-configure.patch \
- "${FILESDIR}"/${P}-makefile.patch
+ default
+
mv configure.in configure.ac || die
eautoreconf
}
src_configure() {
- egamesconf \
- --datadir="${GAMES_DATADIR_BASE}" \
- --with-setgid="${GAMES_GROUP}" \
- --without-gtk \
+ local myconf=(
+ --libdir="${EPREFIX}"/$(get_libdir)/${PN}
+ --with-setgid="nobody"
+ --without-gtk
$(use_with tk tcltk)
+ )
+
+ econf "${myconf[@]}"
}
-src_install() {
- # Keep some important dirs we want to chmod later
- keepdir "${GAMES_DATADIR}"/${PN}/lib/{apex,user,save,bone,info,xtra/help,xtra/music}
+DOCS=( readme
+ z_faq.txt
+ z_update.txt )
+src_install() {
# Install the basic files but remove unneeded crap
- emake DESTDIR="${D}/${GAMES_DATADIR}"/${PN}/ installbase
- rm "${D}${GAMES_DATADIR}"/${PN}/{angdos.cfg,readme,z_faq.txt,z_update.txt}
+ emake DESTDIR="${D}/" installbase
+ rm "${D}"/{angdos.cfg,readme,z_faq.txt,z_update.txt}
# Install everything else and fix the permissions
- dogamesbin zangband
- dodoc readme z_faq.txt z_update.txt
- find "${D}${GAMES_DATADIR}/zangband/lib" -type f -exec chmod a-x \{\} +
-
- prepgamesdirs
- # All users in the games group need write permissions to
- # some important dirs
- fperms -R g+w "${GAMES_DATADIR}"/zangband/lib/{apex,data,save,user}
+ dobin zangband
+
+ einstalldocs
}