summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2020-12-11 22:54:49 -0600
committerErik Mackdanz <stasibear@gentoo.org>2020-12-11 22:55:33 -0600
commit7ef595770692be0d1d14d48bcf68b8c662fdc013 (patch)
tree2ec24e5304edda24063a2440bf859d51723ae2cb /games-roguelike
parentdev-libs/zziplib: Stabilize 0.13.71_p20201021 arm64, #759178 (diff)
downloadgentoo-7ef595770692be0d1d14d48bcf68b8c662fdc013.tar.gz
gentoo-7ef595770692be0d1d14d48bcf68b8c662fdc013.tar.bz2
gentoo-7ef595770692be0d1d14d48bcf68b8c662fdc013.zip
games-roguelike/stone-soup: Correctly use python eclasses for bdeps
Signed-off-by: Erik Mackdanz <stasibear@gentoo.org> Package-Manager: Portage-3.0.12, Repoman-3.0.2
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.25.1-r100.ebuild16
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.25.1.ebuild16
2 files changed, 28 insertions, 4 deletions
diff --git a/games-roguelike/stone-soup/stone-soup-0.25.1-r100.ebuild b/games-roguelike/stone-soup/stone-soup-0.25.1-r100.ebuild
index 984eb6860bc9..58a9e530e1a1 100644
--- a/games-roguelike/stone-soup/stone-soup-0.25.1-r100.ebuild
+++ b/games-roguelike/stone-soup/stone-soup-0.25.1-r100.ebuild
@@ -9,7 +9,7 @@ EAPI=7
LUA_COMPAT=( lua5-{1..3} )
PYTHON_COMPAT=( python3_{6,7,8,9} )
VIRTUALX_REQUIRED="manual"
-inherit desktop distutils-r1 eutils lua-single xdg-utils toolchain-funcs
+inherit desktop python-any-r1 eutils lua-single xdg-utils toolchain-funcs
MY_P="stone_soup-${PV}"
DESCRIPTION="Role-playing roguelike game of exploration and treasure-hunting in dungeons"
@@ -54,7 +54,8 @@ RDEPEND="
DEPEND="${RDEPEND}
app-arch/unzip
dev-lang/perl
- dev-python/pyyaml[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/pyyaml[${PYTHON_USEDEP}]')
sys-devel/flex
tiles? (
sys-libs/ncurses:0
@@ -70,8 +71,14 @@ PATCHES=(
"${FILESDIR}"/rltiles-ldflags-libs.patch
)
+python_check_deps() {
+ has_version "dev-python/pyyaml[${PYTHON_USEDEP}]"
+}
+
pkg_setup() {
+ python-any-r1_pkg_setup
+
if use !ncurses && use !tiles ; then
ewarn "Neither ncurses nor tiles frontend"
ewarn "selected, choosing ncurses only."
@@ -83,6 +90,11 @@ pkg_setup() {
fi
}
+src_prepare() {
+ default
+ python_fix_shebang "${S}/util/species-gen.py"
+}
+
src_compile() {
# Insurance that we're not using bundled lib sources
diff --git a/games-roguelike/stone-soup/stone-soup-0.25.1.ebuild b/games-roguelike/stone-soup/stone-soup-0.25.1.ebuild
index f478d555a48e..69379b34c524 100644
--- a/games-roguelike/stone-soup/stone-soup-0.25.1.ebuild
+++ b/games-roguelike/stone-soup/stone-soup-0.25.1.ebuild
@@ -8,7 +8,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8,9} )
VIRTUALX_REQUIRED="manual"
-inherit desktop distutils-r1 eutils xdg-utils toolchain-funcs
+inherit desktop python-any-r1 eutils xdg-utils toolchain-funcs
MY_P="stone_soup-${PV}"
DESCRIPTION="Role-playing roguelike game of exploration and treasure-hunting in dungeons"
@@ -53,7 +53,8 @@ RDEPEND="
DEPEND="${RDEPEND}
app-arch/unzip
dev-lang/perl
- dev-python/pyyaml[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/pyyaml[${PYTHON_USEDEP}]')
sys-devel/flex
tiles? (
sys-libs/ncurses:0
@@ -69,8 +70,14 @@ PATCHES=(
"${FILESDIR}"/rltiles-ldflags-libs.patch
)
+python_check_deps() {
+ has_version "dev-python/pyyaml[${PYTHON_USEDEP}]"
+}
+
pkg_setup() {
+ python-any-r1_pkg_setup
+
if use !ncurses && use !tiles ; then
ewarn "Neither ncurses nor tiles frontend"
ewarn "selected, choosing ncurses only."
@@ -82,6 +89,11 @@ pkg_setup() {
fi
}
+src_prepare() {
+ default
+ python_fix_shebang "${S}/util/species-gen.py"
+}
+
src_compile() {
# Insurance that we're not using bundled lib sources