summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-09-09 19:13:56 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-10-02 09:41:15 +0300
commitc91384e531b2f1e92cc987c2fefa85d49158a844 (patch)
treefab18af9cf70f37f24d184d4c3e7f951e1e03183 /games-rpg/adonthell
parentdev-libs/libucl: remove failing tests (diff)
downloadgentoo-c91384e531b2f1e92cc987c2fefa85d49158a844.tar.gz
gentoo-c91384e531b2f1e92cc987c2fefa85d49158a844.tar.bz2
gentoo-c91384e531b2f1e92cc987c2fefa85d49158a844.zip
games-rpg/adonthell: update to 0.3.8
Migrated to python3, EAPI7, update license to GPL-2+. Closes: https://bugs.gentoo.org/680762 Closes: https://bugs.gentoo.org/735356 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-rpg/adonthell')
-rw-r--r--games-rpg/adonthell/Manifest1
-rw-r--r--games-rpg/adonthell/adonthell-0.3.8.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/games-rpg/adonthell/Manifest b/games-rpg/adonthell/Manifest
index 84eba2f36f26..1e009bdaf6f6 100644
--- a/games-rpg/adonthell/Manifest
+++ b/games-rpg/adonthell/Manifest
@@ -1 +1,2 @@
DIST adonthell-src-0.3.5.tar.gz 877439 BLAKE2B 995102c30b5557aaa02ab463a9c609251175b1a590e8bc89b457feead74391dc3756c8c06bba580a5f2b02cbe4cd87f27249364be3355409e3507269fb653094 SHA512 bf970b809b22a8563b196d6817553dd58dc9cb09b3bd99eb99d5c8e6f0828cf59965633acd4fdf7835dd9cb732cbb3290d3663521201ece7569cad2f494fb15d
+DIST adonthell-src-0.3.8.tar.gz 889244 BLAKE2B 43b685feaa9ae616fea0eaa7687c72455ef916c9eeaf0dd07724fbaae5e33fb36130252c3c493cff34889cbc6146d76cc9ba2a1ec4e4f20b3b16c188c837d51a SHA512 7a047ec4d01d677c616dcc1f8efff2fecc95c1636172fd6709736de79f485711f169057af5797db85243592b5622f25f69e3393469321d7989c054bb41e17cf3
diff --git a/games-rpg/adonthell/adonthell-0.3.8.ebuild b/games-rpg/adonthell/adonthell-0.3.8.ebuild
new file mode 100644
index 000000000000..ee5853868fc4
--- /dev/null
+++ b/games-rpg/adonthell/adonthell-0.3.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-single-r1
+
+DESCRIPTION="Roleplaying game engine"
+HOMEPAGE="http://adonthell.nongnu.org/"
+SRC_URI="https://savannah.nongnu.org/download/${PN}/${PN}-src-${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ media-libs/freetype
+ media-libs/libogg
+ media-libs/libsdl2[X,video,sound]
+ media-libs/libvorbis
+ media-libs/sdl2-mixer[vorbis]
+ media-libs/sdl2-ttf
+ sys-libs/zlib
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-lang/swig"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS NEWBIE NEWS README )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf \
+ --program-transform-name="s:${PN}-$(ver_cut 1-2):${PN}:" \
+ --disable-py-debug \
+ --with-python=${EPYTHON} \
+ $(use_enable nls) \
+ $(use_enable doc)
+}