summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/arx-fatalis-demo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/arx-fatalis-demo')
-rw-r--r--games-rpg/arx-fatalis-demo/Manifest1
-rw-r--r--games-rpg/arx-fatalis-demo/arx-fatalis-demo-0.ebuild54
-rw-r--r--games-rpg/arx-fatalis-demo/metadata.xml17
3 files changed, 72 insertions, 0 deletions
diff --git a/games-rpg/arx-fatalis-demo/Manifest b/games-rpg/arx-fatalis-demo/Manifest
new file mode 100644
index 000000000000..3ee0d4855c5d
--- /dev/null
+++ b/games-rpg/arx-fatalis-demo/Manifest
@@ -0,0 +1 @@
+DIST arx_demo_english.zip 160545354 SHA256 9e85d4bfa081a4ccc40a1f3722b32c23cd9fa95e91f47d32be76aa62c9fd7187 SHA512 0cbf0d6da1a373ed29edc49c65ed431117c868ec7bcab04166abd59f5d799460faec506baf191c83fa7c61372888009abb260d8a50e28507a5ec8ab7913a9ad7 WHIRLPOOL 2ef662feac747fc7da44c224d46bd2bc9ab48c01c572912df3464dbef04cd47c4c3768e09f26dde27104e62e3c7c9f4ffe828ec2dac53a80467b31533bcc6731
diff --git a/games-rpg/arx-fatalis-demo/arx-fatalis-demo-0.ebuild b/games-rpg/arx-fatalis-demo/arx-fatalis-demo-0.ebuild
new file mode 100644
index 000000000000..c81dca874d0b
--- /dev/null
+++ b/games-rpg/arx-fatalis-demo/arx-fatalis-demo-0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils games
+
+DESCRIPTION="Arx Fatalis demo"
+HOMEPAGE="http://www.arkane-studios.com/uk/arx.php"
+SRC_URI="arx_demo_english.zip"
+
+LICENSE="ArxFatalisDemo"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RESTRICT="fetch"
+
+RDEPEND="games-rpg/arx-libertatis"
+DEPEND="app-arch/cabextract
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please find and download ${SRC_URI} and put it into ${DISTDIR}."
+ einfo "There is a list of possible download locations at"
+ einfo "http://wiki.arx-libertatis.org/Getting_the_game_data#Demo"
+}
+
+src_unpack() {
+ unpack ${A}
+ cabextract Setup1.cab || die "cabextract failed"
+ cabextract Setup2.cab || die "cabextract failed"
+ cabextract Setup3.cab || die "cabextract failed"
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r *.pak bin/*.pak
+ insinto "${GAMES_DATADIR}/${PN}/misc"
+ doins bin/Logo.bmp bin/Arx.ttf
+
+ # convert to lowercase
+ cd "${D}"
+ find . -type f -exec sh -c 'echo "${1}"
+ lower="`echo "${1}" | tr [:upper:] [:lower:]`"
+ [ "${1}" = "${lower}" ] || mv "${1}" "${lower}"' - {} \;
+
+ make_desktop_entry "arx --data-dir=${GAMES_DATADIR}/arx-fatalis-demo" \
+ "Arx Fatalis Demo" arx-libertatis
+
+ prepgamesdirs
+}
diff --git a/games-rpg/arx-fatalis-demo/metadata.xml b/games-rpg/arx-fatalis-demo/metadata.xml
new file mode 100644
index 000000000000..2b3659406eb8
--- /dev/null
+++ b/games-rpg/arx-fatalis-demo/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>hasufell@gentoo.org</email>
+ <name>Julian Ospald</name>
+ <description>Maintainer. Assign bugs to him</description>
+ </maintainer>
+ <maintainer>
+ <email>daniel@constexpr.org</email>
+ <name>Daniel Scharrer</name>
+ <description>Proxy maintainer. CC him on bugs</description>
+ </maintainer>
+</pkgmetadata>
+