summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-07-03 23:09:16 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-07-03 23:12:47 +0200
commiteb89277907b71f9430a2920823b9c7b75a4ea82e (patch)
treeb425a0b843aa972b8bfaf2ae40bb9817ea753654 /games-rpg/manaplus
parentgames-rpg/manaplus: Removed old. (diff)
downloadgentoo-eb89277907b71f9430a2920823b9c7b75a4ea82e.tar.gz
gentoo-eb89277907b71f9430a2920823b9c7b75a4ea82e.tar.bz2
gentoo-eb89277907b71f9430a2920823b9c7b75a4ea82e.zip
games-rpg/manaplus: Sync live ebuild.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'games-rpg/manaplus')
-rw-r--r--games-rpg/manaplus/manaplus-9999.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/games-rpg/manaplus/manaplus-9999.ebuild b/games-rpg/manaplus/manaplus-9999.ebuild
index e7df6f7097d2..2d5897b5d6f1 100644
--- a/games-rpg/manaplus/manaplus-9999.ebuild
+++ b/games-rpg/manaplus/manaplus-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -62,16 +62,17 @@ src_prepare() {
}
src_configure() {
- CONFIG_SHELL=/bin/bash \
- econf \
- --localedir=/usr/share/locale \
- --without-internalsdlgfx \
- $(use_with mumble) \
- $(use_enable nls) \
- $(use_with opengl) \
- --enable-libxml=$(usex pugixml pugixml libxml) \
- $(use_with sdl2) \
+ local myeconfargs=(
+ --localedir=/usr/share/locale
+ --without-internalsdlgfx
+ $(use_with mumble)
+ $(use_enable nls)
+ $(use_with opengl)
+ --enable-libxml=$(usex pugixml pugixml libxml)
+ $(use_with sdl2)
$(use_enable test unittests)
+ )
+ CONFIG_SHELL=/bin/bash econf "${myeconfargs[@]}"
}
src_install() {