summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-01-13 16:45:47 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-01-13 16:50:44 +0100
commitf66396233fcf42b3a42bd6f421703bbec6cfcd65 (patch)
tree1db97649c86a36257f029499a882244c83d86c94 /games-rpg/manaplus
parentdev-perl/ZMQ-LibZMQ3: x86 stable wrt bug #591998 (diff)
downloadgentoo-f66396233fcf42b3a42bd6f421703bbec6cfcd65.tar.gz
gentoo-f66396233fcf42b3a42bd6f421703bbec6cfcd65.tar.bz2
gentoo-f66396233fcf42b3a42bd6f421703bbec6cfcd65.zip
games-rpg/manaplus: Bump to version 1.7.1.7
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'games-rpg/manaplus')
-rw-r--r--games-rpg/manaplus/Manifest1
-rw-r--r--games-rpg/manaplus/manaplus-1.7.1.7.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/games-rpg/manaplus/Manifest b/games-rpg/manaplus/Manifest
index b762c57a5482..89cd0bf9a5e9 100644
--- a/games-rpg/manaplus/Manifest
+++ b/games-rpg/manaplus/Manifest
@@ -1,2 +1,3 @@
DIST manaplus-1.6.11.5.tar.xz 11744332 SHA256 cb5ac8a8df93b9a6698a53048a64e6b6f1d431e8da0c0a3b55b01e5a58dea3c5 SHA512 3b934ec9403a2eefd637d3193f16069d208635eea484ebcbf5780bd0dd42eba1eb179467bc2f616e4c432ae61289f6ed96926c985707885190066c2b17c3b348 WHIRLPOOL e12d69aa4f469b5e66a43feecf62910c742ff957a4a1767f060870fdec098e81743f1166e68cdc6b035fa0b461154e6de5622bb30d3c5e467ae26df4f5755805
DIST manaplus-1.6.12.24.tar.xz 11762256 SHA256 980967aaf530effbd8e59ececa87af992f55bdf97f0900bc0a9b6d235abcc4bc SHA512 b39f5c1fdab4c9fc95b09f83f0914852d4c6e3754a3bca7ede2208add9f070e7d7decddb0fc73ced8ecbe93ae7f5016bf1843630fa18f2799c0d26a96aaf58e4 WHIRLPOOL 9ee09b2ddda084aabe5c0bdddf5c9ad0e5c6264742996edcd5f0824a8a3757b9bddfa401bbf570c496fc040008a28637c215f98a65c10c5d1b08ff24652f2c39
+DIST manaplus-1.7.1.7.tar.xz 11762860 SHA256 a6f7169d1c5103cfdb09f9b9bde984b9953209e6affc599b3597abdece17abb3 SHA512 319cbf0ca198142f303a7c35a83f6cd477c896d855ec022a829eed106e8b107bc2a306a93b2f38b7d4cbe0b2909cd10d8345c28fece92e80842405d45fed59c1 WHIRLPOOL 6e69aa6bdefa22e2ad65d2066adcbb7362ffcd8ea40cc346f30da7d83b072f5bf78d5bf623a480fac044b36411d1d14ea61be8a7b7ae6292ac9faad92563310a
diff --git a/games-rpg/manaplus/manaplus-1.7.1.7.ebuild b/games-rpg/manaplus/manaplus-1.7.1.7.ebuild
new file mode 100644
index 000000000000..c3fe215b2d3c
--- /dev/null
+++ b/games-rpg/manaplus/manaplus-1.7.1.7.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="OpenSource 2D MMORPG client for Evol Online and The Mana World"
+HOMEPAGE="http://manaplus.evolonline.org"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ManaPlus/ManaPlus.git"
+else
+ SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="mumble nls opengl pugixml +sdl2 test"
+
+RDEPEND="
+ >=dev-games/physfs-1.0.0
+ media-fonts/dejavu
+ media-fonts/liberation-fonts
+ media-fonts/mplus-outline-fonts
+ media-fonts/wqy-microhei
+ media-libs/libpng:0=
+ net-misc/curl
+ sys-libs/zlib
+ x11-apps/xmessage
+ x11-libs/libX11
+ x11-misc/xdg-utils
+ mumble? ( media-sound/mumble )
+ nls? ( virtual/libintl )
+ opengl? ( virtual/opengl )
+ pugixml? ( dev-libs/pugixml )
+ !pugixml? ( dev-libs/libxml2 )
+ sdl2? (
+ media-libs/libsdl2[X,opengl?,video]
+ media-libs/sdl2-gfx
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-mixer[vorbis]
+ media-libs/sdl2-net
+ media-libs/sdl2-ttf
+ )
+ !sdl2? (
+ media-libs/libsdl[X,opengl?,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ CONFIG_SHELL=/bin/bash \
+ econf \
+ --localedir=/usr/share/locale \
+ --without-internalsdlgfx \
+ $(use_with mumble) \
+ $(use_enable nls) \
+ $(use_with opengl) \
+ --enable-libxml=$(usex pugixml pugixml libxml) \
+ $(use_with sdl2) \
+ $(use_enable test unittests)
+}
+
+src_install() {
+ default
+
+ local destpath="/usr/share/${PN}"
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${destpath}"/data/fonts/dejavusans-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${destpath}"/data/fonts/dejavusans.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono-Bold.ttf "${destpath}"/data/fonts/dejavusansmono-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono.ttf "${destpath}"/data/fonts/dejavusansmono.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed-Bold.ttf "${destpath}"/data/fonts/dejavuserifcondensed-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed.ttf "${destpath}"/data/fonts/dejavuserifcondensed.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationMono-Bold.ttf "${destpath}"/data/fonts/liberationsansmono-bold.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationMono-Regular.ttf "${destpath}"/data/fonts/liberationsansmono.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationSans-Bold.ttf "${destpath}"/data/fonts/liberationsans-bold.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationSans-Regular.ttf "${destpath}"/data/fonts/liberationsans.ttf
+ dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-bold.ttf "${destpath}"/data/fonts/mplus-1p-bold.ttf
+ dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-regular.ttf "${destpath}"/data/fonts/mplus-1p-regular.ttf
+ dosym /usr/share/fonts/wqy-microhei/wqy-microhei.ttc "${destpath}"/data/fonts/wqy-microhei.ttf
+}
+
+src_test() {
+ make check
+}