summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/nwmouse/nwmouse-20090906.183839.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/nwmouse/nwmouse-20090906.183839.ebuild')
-rw-r--r--games-rpg/nwmouse/nwmouse-20090906.183839.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/games-rpg/nwmouse/nwmouse-20090906.183839.ebuild b/games-rpg/nwmouse/nwmouse-20090906.183839.ebuild
new file mode 100644
index 000000000000..3b27c80b1275
--- /dev/null
+++ b/games-rpg/nwmouse/nwmouse-20090906.183839.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit games
+
+DESCRIPTION="Hardware mouse cursors for Neverwinter Nights"
+HOMEPAGE="http://home.roadrunner.com/~nwmovies/"
+SRC_URI="http://dev.gentoo.org/~calchan/distfiles/${P}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="nwmovies Artistic"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RESTRICT="strip"
+
+RDEPEND="
+ >=games-rpg/nwn-1.68-r4
+ games-rpg/nwn-data
+ sys-libs/glibc
+ >=dev-libs/elfutils-0.155-r1[abi_x86_32(-)]
+ >=media-libs/libsdl-1.2.15-r5[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXcursor[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]"
+
+# I've looked at this stuff, and I can't find the problem myself, so I'm just
+# removing the warnings. If someone feels like finding the patch, that would be
+# great and I'll gladly include it.
+dir="${GAMES_PREFIX_OPT}/nwn"
+QA_PREBUILT="${dir:1}/nwmouse.so
+ ${dir:1}/nwmouse/libdis/libdisasm.so"
+
+src_install() {
+ # libelf moved to games-rpg/nwn, see bug #210562
+ exeinto "${dir}"
+ doexe "${PN}.so"
+ exeinto "${dir}/${PN}/libdis"
+ doexe "libdisasm.so"
+ insinto "${dir}/${PN}/cursors"
+ doins -r cursors/*
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "When starting nwn the next time, nwmouse will scan the nwmain"
+ elog "binary for its hooks, store this information in:"
+ elog " ${dir}/nwmouse.ini"
+ elog "and exit. This is normal."
+ elog
+ elog "You will have to remove this file whenever you update nwn."
+}