summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/soltys/soltys-1.0-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/soltys/soltys-1.0-r1.ebuild')
-rw-r--r--games-rpg/soltys/soltys-1.0-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/games-rpg/soltys/soltys-1.0-r1.ebuild b/games-rpg/soltys/soltys-1.0-r1.ebuild
new file mode 100644
index 000000000000..e8b8abe36bf7
--- /dev/null
+++ b/games-rpg/soltys/soltys-1.0-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit unpacker eutils games
+
+DESCRIPTION="Classic adventure game"
+HOMEPAGE="http://wiki.scummvm.org/index.php/Soltys"
+SRC_URI="linguas_en? ( mirror://sourceforge/scummvm/${PN}-en-v${PV}.zip )
+ linguas_es? ( mirror://sourceforge/scummvm/${PN}-es-v${PV}.zip )
+ linguas_pl? ( mirror://sourceforge/scummvm/${PN}-pl-v${PV}.zip )
+ !linguas_en? ( !linguas_es? ( !linguas_pl? ( mirror://sourceforge/scummvm/${PN}-en-v${PV}.zip ) ) )
+ http://www.scummvm.org/images/cat-soltys.png"
+
+LICENSE="Soltys"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="linguas_en linguas_es linguas_pl"
+
+RDEPEND=">=games-engines/scummvm-1.5"
+DEPEND="$(unpacker_src_uri_depends)"
+
+S=${WORKDIR}
+
+src_unpack() {
+ if use linguas_en || ( ! use linguas_en && ! use linguas_es && ! use linguas_pl ) ; then
+ mkdir -p en || die
+ unpacker ${PN}-en-v${PV}.zip
+ mv vol.{cat,dat} en/ || die
+ fi
+ if use linguas_es ; then
+ mkdir -p es || die
+ unpacker ${PN}-es-v${PV}.zip
+ mv soltys-es-v1-0/vol.{cat,dat} es/ || die
+ fi
+ if use linguas_pl ; then
+ mkdir -p pl || die
+ unpacker ${PN}-pl-v${PV}.zip
+ mv vol.{cat,dat} pl/ || die
+ fi
+}
+
+src_prepare() {
+ rm -rf license.txt soltys-es-v1-0
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r *
+ newicon "${DISTDIR}"/cat-soltys.png soltys.png
+ if use linguas_en || ( ! use linguas_en && ! use linguas_es && ! use linguas_pl ) ; then
+ games_make_wrapper soltys-en "scummvm -f -p \"${GAMES_DATADIR}/${PN}/en\" soltys" .
+ make_desktop_entry ${PN}-en "Soltys (English)" soltys
+ fi
+ if use linguas_es ; then
+ games_make_wrapper soltys-es "scummvm -f -p \"${GAMES_DATADIR}/${PN}/es\" soltys" .
+ make_desktop_entry ${PN}-es "Soltys (Español)" soltys
+ fi
+ if use linguas_pl ; then
+ games_make_wrapper soltys-pl "scummvm -f -p \"${GAMES_DATADIR}/${PN}/pl\" soltys" .
+ make_desktop_entry ${PN}-pl "Soltys (Polski)" soltys
+ fi
+ prepgamesdirs
+}