summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-05-06 16:09:20 +0100
committerJames Le Cuirot <chewi@gentoo.org>2019-05-06 16:09:20 +0100
commit46a45ff08e849676f4f6c5c61f5baa74a82ae02b (patch)
treee0fbfacd11945294321768b8976a3ab1edc68db5 /games-rpg
parentprofiles: Mask games-rpg/costume-quest in non-glibc/multilib profiles (diff)
downloadgentoo-46a45ff08e849676f4f6c5c61f5baa74a82ae02b.tar.gz
gentoo-46a45ff08e849676f4f6c5c61f5baa74a82ae02b.tar.bz2
gentoo-46a45ff08e849676f4f6c5c61f5baa74a82ae02b.zip
games-rpg/costume-quest: New package
This only supports the GOG version for now. This is probably the GOG version number rather than the upstream one but I can't find an upstream one. Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/costume-quest/Manifest1
-rw-r--r--games-rpg/costume-quest/costume-quest-2.0.0.3.ebuild55
-rw-r--r--games-rpg/costume-quest/metadata.xml8
3 files changed, 64 insertions, 0 deletions
diff --git a/games-rpg/costume-quest/Manifest b/games-rpg/costume-quest/Manifest
new file mode 100644
index 000000000000..5c5e94d9aa46
--- /dev/null
+++ b/games-rpg/costume-quest/Manifest
@@ -0,0 +1 @@
+DIST gog_costume_quest_2.0.0.3.sh 565855108 BLAKE2B 779d0b0b408921589bb78256cf1b69b912a57143472e3f2d7b6aebf95c07fcd8b86831234519a0c7a30b15c645668d81c0c7502d058465caa337f76ad0311cdf SHA512 9e7ab258b860ec6ee5bef3aab1e745d3dfa02defd6011d195925b50c7a0fd068f4e9e7d483734ad002bcc8353a436a349d9246d947c863b2e3d63e17c41acd71
diff --git a/games-rpg/costume-quest/costume-quest-2.0.0.3.ebuild b/games-rpg/costume-quest/costume-quest-2.0.0.3.ebuild
new file mode 100644
index 000000000000..822f7a146872
--- /dev/null
+++ b/games-rpg/costume-quest/costume-quest-2.0.0.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop unpacker xdg-utils
+
+DESCRIPTION="A Halloween adventure from Tim Schafer's Double Fine Productions"
+HOMEPAGE="https://www.doublefine.com"
+SRC_URI="gog_${PN//-/_}_${PV}.sh"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+RDEPEND="
+ media-libs/glu[abi_x86_32]
+ media-libs/libsdl2[abi_x86_32,joystick,opengl,sound,threads,video]
+ sys-libs/zlib[abi_x86_32]
+ virtual/opengl[abi_x86_32]
+"
+
+S="${WORKDIR}/data/noarch/game"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR}/*"
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_prepare() {
+ default
+
+ # I think our SDL2 package has a newer database.
+ rm -v Data/Config/SDLGamepad.config || die
+}
+
+src_install() {
+ exeinto "${DIR}"
+ newexe Cq.bin.x86 Cq.bin
+ dosym "${DIR}"/Cq.bin /usr/bin/${PN}
+
+ insinto "${DIR}"
+ doins -r DFCONFIG Data/ Linux/ OGL/ Win/
+
+ exeinto "${DIR}/lib"
+ doexe lib/libfmod*.so
+
+ newicon -s 256 CostumeQuest.png ${PN}.png
+ make_desktop_entry ${PN} "Costume Quest"
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }
diff --git a/games-rpg/costume-quest/metadata.xml b/games-rpg/costume-quest/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-rpg/costume-quest/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>