summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-07-26 11:28:06 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-07-26 11:51:02 +0200
commit66ccb27e363fbd2845d1ee455dd6929993beae48 (patch)
tree6f90d373e27e87cf891eed1f59fb229cdfc8b1a6 /games-rpg
parentdev-libs/libnatspec: Removed old. (diff)
downloadgentoo-66ccb27e363fbd2845d1ee455dd6929993beae48.tar.gz
gentoo-66ccb27e363fbd2845d1ee455dd6929993beae48.tar.bz2
gentoo-66ccb27e363fbd2845d1ee455dd6929993beae48.zip
games-rpg/manaplus: Bump to version 1.7.7.22
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/manaplus/Manifest1
-rw-r--r--games-rpg/manaplus/manaplus-1.7.7.22.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/games-rpg/manaplus/Manifest b/games-rpg/manaplus/Manifest
index c8d0e4c4bd42..686263993922 100644
--- a/games-rpg/manaplus/Manifest
+++ b/games-rpg/manaplus/Manifest
@@ -1,2 +1,3 @@
DIST manaplus-1.7.6.24.tar.xz 14864072 SHA256 d5504420d2a1eb0de0459ff738257636a321fcd871dceb21ca086a2a735a0c07 SHA512 71e030854abbaa19ad6a460598d4506e9fad8ff0cfe8c26926415ebd4a203b438dc3a578cb583225fa4c36b66cf0a5d580e0dd6dfe62aedee783d4aba683b8d0 WHIRLPOOL 791df12e1846306b1ed6a619671d91ade40a82057a8d3c394aea59e85eca539a95f988c548a308474c9eecfce23079d536fb7a49d34c6ecdffac59022f100cbf
+DIST manaplus-1.7.7.22.tar.xz 14894836 SHA256 b059067e7afba041b21a5cb266ed0ab9587da17b327c46952cccc691408f5515 SHA512 6dff569421123e1a3f7fb215f80da3ae20958510bc7ae6a252b85e1afe229e7e1398522ec1ddc9c3ddbde26dcd8ccbbe632b1307ff1527927cd1dc0bcad82f67 WHIRLPOOL 890a8875d3bd8294cc87409b03efad12dd104dee8b5b1eac9d200ceb4c4c7ae6d9ebf6901fea7a57e69b1415d165524001841cc09521ccb4f1976e548169a3b1
DIST manaplus-1.7.7.8.tar.xz 14860880 SHA256 4c9473c5423076e9b7010e78dbb85d2c0aa63edcf7577fe4048adba6b6adbea5 SHA512 9316297d5d766997913a465197da336516a8c1dbb30e193a1dca6ad083aa990788a147481a09cb6bcc044fdce575222c21797cef47107123141296c354639128 WHIRLPOOL 2d550f29e7d42549c095a1bf0db398d903e59e4f054d5751fd19259fa73615567a58ff1412aa97757efde18aad64fadf0220b8ad9f8e8ca44a5cdea1f564b875
diff --git a/games-rpg/manaplus/manaplus-1.7.7.22.ebuild b/games-rpg/manaplus/manaplus-1.7.7.22.ebuild
new file mode 100644
index 000000000000..2d5897b5d6f1
--- /dev/null
+++ b/games-rpg/manaplus/manaplus-1.7.7.22.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="OpenSource 2D MMORPG client for Evol Online and The Mana World"
+HOMEPAGE="http://manaplus.evolonline.org"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ManaPlus/ManaPlus.git"
+else
+ SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="mumble nls opengl pugixml +sdl2 test"
+
+RDEPEND="
+ >=dev-games/physfs-1.0.0
+ media-fonts/dejavu
+ media-fonts/liberation-fonts
+ media-fonts/mplus-outline-fonts
+ media-fonts/wqy-microhei
+ media-libs/libpng:0=
+ net-misc/curl
+ sys-libs/zlib
+ x11-apps/xmessage
+ x11-libs/libX11
+ x11-misc/xdg-utils
+ mumble? ( media-sound/mumble )
+ nls? ( virtual/libintl )
+ opengl? ( virtual/opengl )
+ pugixml? ( dev-libs/pugixml )
+ !pugixml? ( dev-libs/libxml2 )
+ sdl2? (
+ media-libs/libsdl2[X,opengl?,video]
+ media-libs/sdl2-gfx
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-mixer[vorbis]
+ media-libs/sdl2-net
+ media-libs/sdl2-ttf
+ )
+ !sdl2? (
+ media-libs/libsdl[X,opengl?,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --localedir=/usr/share/locale
+ --without-internalsdlgfx
+ $(use_with mumble)
+ $(use_enable nls)
+ $(use_with opengl)
+ --enable-libxml=$(usex pugixml pugixml libxml)
+ $(use_with sdl2)
+ $(use_enable test unittests)
+ )
+ CONFIG_SHELL=/bin/bash econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ local destpath="/usr/share/${PN}"
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${destpath}"/data/fonts/dejavusans-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${destpath}"/data/fonts/dejavusans.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono-Bold.ttf "${destpath}"/data/fonts/dejavusansmono-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono.ttf "${destpath}"/data/fonts/dejavusansmono.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed-Bold.ttf "${destpath}"/data/fonts/dejavuserifcondensed-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed.ttf "${destpath}"/data/fonts/dejavuserifcondensed.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationMono-Bold.ttf "${destpath}"/data/fonts/liberationsansmono-bold.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationMono-Regular.ttf "${destpath}"/data/fonts/liberationsansmono.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationSans-Bold.ttf "${destpath}"/data/fonts/liberationsans-bold.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationSans-Regular.ttf "${destpath}"/data/fonts/liberationsans.ttf
+ dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-bold.ttf "${destpath}"/data/fonts/mplus-1p-bold.ttf
+ dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-regular.ttf "${destpath}"/data/fonts/mplus-1p-regular.ttf
+ dosym /usr/share/fonts/wqy-microhei/wqy-microhei.ttc "${destpath}"/data/fonts/wqy-microhei.ttf
+}
+
+src_test() {
+ make check
+}