summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-01-31 22:53:48 +0000
committerJames Le Cuirot <chewi@gentoo.org>2021-01-31 22:53:48 +0000
commit9b3a82491c523a12fbb33a0fa9ac195e525b2f0c (patch)
tree18acfb8af2620aad04c89e75fada475a70e79ad0 /games-rpg
parentnet-mail/rss2email: Drop broken support for py39 (diff)
downloadgentoo-9b3a82491c523a12fbb33a0fa9ac195e525b2f0c.tar.gz
gentoo-9b3a82491c523a12fbb33a0fa9ac195e525b2f0c.tar.bz2
gentoo-9b3a82491c523a12fbb33a0fa9ac195e525b2f0c.zip
games-rpg/deponia-doomsday: New package
Package-Manager: Portage-3.0.14, Repoman-3.0.1 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/deponia-doomsday/Manifest1
-rw-r--r--games-rpg/deponia-doomsday/deponia-doomsday-1.2.0267.ebuild71
-rw-r--r--games-rpg/deponia-doomsday/metadata.xml11
3 files changed, 83 insertions, 0 deletions
diff --git a/games-rpg/deponia-doomsday/Manifest b/games-rpg/deponia-doomsday/Manifest
new file mode 100644
index 000000000000..37e363e8a7dc
--- /dev/null
+++ b/games-rpg/deponia-doomsday/Manifest
@@ -0,0 +1 @@
+DIST Deponia4_1.2.0267_DEB_Full_Multi_Daedalic_ESD.tar 3179350835 BLAKE2B caf1995f2a6204b083e7b462ec0ab45e8c84cf2bd626fbc20fbac36e066551a267cad391c07293dff5219c555523a68dc7e7a351c948a2d049af35be6ec5573c SHA512 daf3427ff3dd4568bb84a11fd63b630fa1de61331ceb84f70f7668c56abd2908e0cfdf897d9f1caefdb6d51d1082cfce435eb4378d1eeb9b0a3598edd6350c07
diff --git a/games-rpg/deponia-doomsday/deponia-doomsday-1.2.0267.ebuild b/games-rpg/deponia-doomsday/deponia-doomsday-1.2.0267.ebuild
new file mode 100644
index 000000000000..bbb377287f74
--- /dev/null
+++ b/games-rpg/deponia-doomsday/deponia-doomsday-1.2.0267.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop wrapper
+
+MY_PN="Deponia Doomsday"
+DESCRIPTION="The fourth and final instalment of the Deponia point-and-click adventures"
+HOMEPAGE="https://www.daedalic.com/deponia"
+SRC_URI="Deponia4_${PV}_DEB_Full_Multi_Daedalic_ESD.tar"
+LICENSE="all-rights-reserved BSD LGPL-2.1 MIT OFL-1.1"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="bonus"
+RESTRICT="bindist fetch splitdebug strip"
+
+# Bundles libopenal.so but 1.20.0 and later are not compatible because
+# the game uses the SelectResampler function, which was inlined.
+
+RDEPEND="
+ media-libs/libpng-compat:1.2
+ media-libs/libsdl2[opengl,video]
+ sys-libs/zlib
+ virtual/opengl
+"
+
+S="${WORKDIR}/${MY_PN}"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " https://www.humblebundle.com/store/${PN}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_prepare() {
+ default
+ rm libs64/libz.so.1 || die
+}
+
+src_install() {
+ exeinto "${DIR}"
+ doexe Deponia4
+
+ make_wrapper \
+ ${PN} \
+ "env SDL_DYNAMIC_API=\"${EPREFIX}/usr/$(get_libdir)/libSDL2-2.0.so.0\" ./Deponia4" \
+ "${DIR}" \
+ "${DIR}/lib"
+
+ insinto "${DIR}"
+ doins -r \
+ config.ini \
+ data.vis \
+ version.txt \
+ characters/ \
+ lua/ \
+ scenes/ \
+ videos/
+
+ use bonus && doins -r "bonus content/"
+
+ exeinto "${DIR}"/lib
+ doexe libs64/*
+
+ make_desktop_entry ${PN} "${MY_PN}" applications-games
+ dodoc changes.txt documents/licenses/readme.txt
+}
diff --git a/games-rpg/deponia-doomsday/metadata.xml b/games-rpg/deponia-doomsday/metadata.xml
new file mode 100644
index 000000000000..78d4f370ee3c
--- /dev/null
+++ b/games-rpg/deponia-doomsday/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="bonus">Install the bonus content (Art Book, Concept Art, Soundtrack)</flag>
+ </use>
+</pkgmetadata>