summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-02-16 10:01:35 +0100
committerFlorian Schmaus <flow@gentoo.org>2023-02-16 10:01:49 +0100
commit95adb59c642ad5289e582af07c34c9e2ccf0d1ae (patch)
tree81615f0bd5e2a83effbd62fdfaa73fc368fb1d2c /games-simulation/EmptyEpsilon/EmptyEpsilon-2021.06.23-r1.ebuild
parentgames-simulation/EmptyEpsilon: add github upstream metadata (diff)
downloadgentoo-95adb59c642ad5289e582af07c34c9e2ccf0d1ae.tar.gz
gentoo-95adb59c642ad5289e582af07c34c9e2ccf0d1ae.tar.bz2
gentoo-95adb59c642ad5289e582af07c34c9e2ccf0d1ae.zip
games-simulation/EmptyEpsilon: drop 2021.06.23-r1
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'games-simulation/EmptyEpsilon/EmptyEpsilon-2021.06.23-r1.ebuild')
-rw-r--r--games-simulation/EmptyEpsilon/EmptyEpsilon-2021.06.23-r1.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/games-simulation/EmptyEpsilon/EmptyEpsilon-2021.06.23-r1.ebuild b/games-simulation/EmptyEpsilon/EmptyEpsilon-2021.06.23-r1.ebuild
deleted file mode 100644
index c1ff6c877b43..000000000000
--- a/games-simulation/EmptyEpsilon/EmptyEpsilon-2021.06.23-r1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake toolchain-funcs
-
-DESCRIPTION="A spaceship bridge simulator game"
-HOMEPAGE="https://daid.github.io/EmptyEpsilon/"
-# This bundles SeriousProton as the build system does not support using
-# a separate SeriousProton instance (and currently EmptyEpsilon seems to
-# be the only consumer).
-SRC_URI="https://github.com/daid/EmptyEpsilon/archive/EE-${PV}.tar.gz -> EmptyEpsilon-${PV}.tar.gz
- https://github.com/daid/SeriousProton/archive/EE-${PV}.tar.gz -> SeriousProton-${PV}.tar.gz"
-
-# EmptyEpsilon is mostly licensed under GPL, however the art ressources
-# use Creative Commons and the bundled SeriousProton is MIT-licensed.
-LICENSE="GPL-2 CC-BY-SA-3.0 MIT"
-SLOT="0"
-KEYWORDS="amd64"
-
-RDEPEND="
- >=dev-cpp/json11-1.0.0
- media-libs/libglvnd
- media-libs/libsfml
- >=media-libs/glm-0.9.9.8
-"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/EmptyEpsilon-EE-${PV}"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} == "binary" ]]; then
- return
- fi
-
- if tc-is-gcc; then
- if [[ $(gcc-major-version) -lt 11 ]]; then
- # ld: /usr/lib64/libsfml-audio.so: undefined reference to `std::__throw_bad_array_new_length()@GLIBCXX_3.a4.29'
- eerror "${PN} requires GCC >= 11. Run gcc-config to switch your default compiler."
- die "Need at least GCC >= 11"
- fi
- fi
-}
-
-src_prepare() {
- eapply "${FILESDIR}/${PN}-Install-EmptyEpsilon.desktop.patch"
- eapply "${FILESDIR}/${PN}-Make-CMake-call-find_package-glm.patch"
- eapply --directory="${WORKDIR}/SeriousProton-EE-${PV}" \
- "${FILESDIR}/SeriousProton-Unbundle-json11.patch"
-
- eapply_user
-
- cmake_src_prepare
-}
-
-src_configure() {
- local version=( $(ver_rs 1- ' ') )
- local mycmakeargs=(
- -DSERIOUS_PROTON_DIR="${WORKDIR}/SeriousProton-EE-${PV}/"
- -DOpenGL_GL_PREFERENCE=GLVND
- -DCPACK_PACKAGE_VERSION="${PV}"
- -DCPACK_PACKAGE_VERSION_MAJOR="${version[0]}"
- -DCPACK_PACKAGE_VERSION_MINOR="${version[1]}"
- -DCPACK_PACKAGE_VERSION_PATCH="${version[2]}"
- )
-
- cmake_src_configure
-}