summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild')
-rw-r--r--games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild b/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
new file mode 100644
index 000000000000..f13546c7a2e3
--- /dev/null
+++ b/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+MY_OGG=danslatristesse2-48.ogg
+DESCRIPTION="3D tabletennis game"
+HOMEPAGE="http://cannonsmash.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/csmash-${PV}.tar.gz
+ vorbis? ( http://nan.p.utmc.or.jp/${MY_OGG} )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="vorbis nls"
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer[vorbis?]
+ media-libs/sdl-image[jpeg,png]
+ x11-libs/gtk+:2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/csmash-${PV}
+
+src_unpack() {
+ unpack csmash-${PV}.tar.gz
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-x-inc.patch \
+ "${FILESDIR}"/${P}-sizeof-cast.patch \
+ "${FILESDIR}"/${P}-gcc41.patch \
+ "${FILESDIR}"/${P}-flags.patch
+ if use vorbis ; then
+ sed -i \
+ -e "s:${MY_OGG}:${GAMES_DATADIR}/csmash/${MY_OGG}:" ttinc.h \
+ || die "sed failed"
+ fi
+}
+
+src_configure() {
+ egamesconf \
+ $(use_enable nls) \
+ --datadir="${GAMES_DATADIR_BASE}"
+}
+
+src_compile() {
+ emake \
+ localedir="/usr/share"
+}
+
+src_install() {
+ default
+ if use vorbis ; then
+ insinto "${GAMES_DATADIR}"/csmash
+ doins "${DISTDIR}"/${MY_OGG}
+ fi
+ newicon win32/orange.ico ${PN}.ico
+ make_desktop_entry csmash "Cannon Smash" /usr/share/pixmaps/${PN}.ico
+ prepgamesdirs
+}