summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-simulation/corsix-th/corsix-th-0.21-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-simulation/corsix-th/corsix-th-0.21-r1.ebuild')
-rw-r--r--games-simulation/corsix-th/corsix-th-0.21-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/games-simulation/corsix-th/corsix-th-0.21-r1.ebuild b/games-simulation/corsix-th/corsix-th-0.21-r1.ebuild
new file mode 100644
index 000000000000..e0a87fb1a91c
--- /dev/null
+++ b/games-simulation/corsix-th/corsix-th-0.21-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils cmake-utils games
+
+MY_P="CorsixTH-${PV}-Source"
+
+DESCRIPTION="Open source clone of Theme Hospital"
+HOMEPAGE="http://code.google.com/p/corsix-th/"
+SRC_URI="http://corsix-th.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ffmpeg truetype opengl +sdl +sound +midi"
+REQUIRED_USE="|| ( sdl opengl )"
+
+RDEPEND=">=dev-lang/lua-5.1
+ media-libs/libsdl[X]
+ ffmpeg? ( virtual/ffmpeg )
+ truetype? ( media-libs/freetype:2 )
+ opengl? ( virtual/opengl )
+ sound? ( media-libs/sdl-mixer )
+ midi? ( media-libs/sdl-mixer[timidity] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-nodoc.patch"
+
+ # Use a coherent naming for installation dir
+ epatch "${FILESDIR}/${P}-naming.patch"
+}
+
+src_configure() {
+ local mycmakeargs="$(cmake-utils_use_with opengl OPENGL) \
+ $(cmake-utils_use_with sdl SDL) \
+ $(cmake-utils_use_with sound AUDIO) \
+ $(cmake-utils_use_with truetype FREETYPE2) \
+ $(cmake-utils_use_with ffmpeg MOVIES) \
+ -DCMAKE_INSTALL_PREFIX=${GAMES_DATADIR}"
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ DOCS="CorsixTH/README.txt CorsixTH/changelog.txt" cmake-utils_src_install
+ games_make_wrapper ${PN} "${GAMES_DATADIR}/${PN}/CorsixTH" || die
+ make_desktop_entry ${PN} ${PN} \
+ "${GAMES_DATADIR}/${PN}/CorsixTH.ico"
+ prepgamesdirs
+}