summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-simulation/gl117
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-simulation/gl117')
-rw-r--r--games-simulation/gl117/Manifest1
-rw-r--r--games-simulation/gl117/files/gl117-1.3.2-mode.patch12
-rw-r--r--games-simulation/gl117/gl117-1.3.2.ebuild38
-rw-r--r--games-simulation/gl117/metadata.xml8
4 files changed, 59 insertions, 0 deletions
diff --git a/games-simulation/gl117/Manifest b/games-simulation/gl117/Manifest
new file mode 100644
index 000000000000..c4d143367f64
--- /dev/null
+++ b/games-simulation/gl117/Manifest
@@ -0,0 +1 @@
+DIST gl-117-1.3.2-src.tar.bz2 2411075 SHA256 64bd0190a102725c76eba4983a5d79a0979ec42a087c56c8025b461f6e0e6ffb SHA512 1d2382576c6399d8c84d56ddc7eb2b11b9e1e3ffeebcc1bd30e258ef231626d15d1be649f8c791f30e4f2f78aca2b4290c5d08036c5f482eef01eda8f4f48b5f WHIRLPOOL a94ec54e7b4d436f65932c53e24da96223de93a2382188f0b449282de20f132899d519dec898682c9a0e07a0a8621b403bb74a416454a0da86811f1066889ef1
diff --git a/games-simulation/gl117/files/gl117-1.3.2-mode.patch b/games-simulation/gl117/files/gl117-1.3.2-mode.patch
new file mode 100644
index 000000000000..c74e07c1cafd
--- /dev/null
+++ b/games-simulation/gl117/files/gl117-1.3.2-mode.patch
@@ -0,0 +1,12 @@
+--- src/main.cpp.orig 2010-07-13 09:35:18.374122609 +0100
++++ src/main.cpp 2010-07-13 09:35:45.334955120 +0100
+@@ -71,8 +71,7 @@ int mode = 0;
+
+ // pre-defined screen resolutions (x, y, bpp, fullscreen)
+ int resolution [4] [4] =
+- { { 1024, 768, 32, 1 },
+- { 800, 600, 32, 1 },
++ { { 800, 600, 32, 1 },
+ { 640, 480, 32, 1 },
+ { 640, 480, 32, 0 } };
+
diff --git a/games-simulation/gl117/gl117-1.3.2.ebuild b/games-simulation/gl117/gl117-1.3.2.ebuild
new file mode 100644
index 000000000000..479f53b7eca5
--- /dev/null
+++ b/games-simulation/gl117/gl117-1.3.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+MY_P="gl-117-${PV}-src"
+DESCRIPTION="An action flight simulator"
+HOMEPAGE="http://www.heptargon.de/gl-117/gl-117.html"
+SRC_URI="mirror://sourceforge/gl-117/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,joystick,opengl,video]
+ media-libs/sdl-mixer[mod]
+ virtual/opengl
+ virtual/glu
+ media-libs/freeglut"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-mode.patch
+}
+
+src_install() {
+ DOCS="doc/gl-117.pdf AUTHORS ChangeLog FAQ NEWS README" \
+ default
+ newicon doc/src/falcon.jpg ${PN}.jpg
+ make_desktop_entry gl-117 GL-117 /usr/share/pixmaps/${PN}.jpg
+ doman doc/gl-117.6
+ prepgamesdirs
+}
diff --git a/games-simulation/gl117/metadata.xml b/games-simulation/gl117/metadata.xml
new file mode 100644
index 000000000000..dde59ceb2927
--- /dev/null
+++ b/games-simulation/gl117/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">gl-117</remote-id>
+ </upstream>
+</pkgmetadata>