summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <stefan.strogin@gmail.com>2019-03-03 17:45:35 +0200
committerJames Le Cuirot <chewi@gentoo.org>2019-03-06 22:34:58 +0000
commitbed5ab3bc1fc1c4de95067bf365c861a52e24c61 (patch)
tree08f0881bc2a0b2a52930cb590b18dbd59cf7d6a5 /games-simulation/lincity-ng
parentsys-kernel/linux-headers: package arch/*/kernel/syscalls, bug #679630 (diff)
downloadgentoo-bed5ab3bc1fc1c4de95067bf365c861a52e24c61.tar.gz
gentoo-bed5ab3bc1fc1c4de95067bf365c861a52e24c61.tar.bz2
gentoo-bed5ab3bc1fc1c4de95067bf365c861a52e24c61.zip
games-simulation/lincity-ng: bump version to 2.9_beta; EAPI=7
Drop games eclass; update homepage, SRC_URI and licenses; fix prefixed install; some minor and stylistic changes. Closes: https://bugs.gentoo.org/604618 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11235 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-simulation/lincity-ng')
-rw-r--r--games-simulation/lincity-ng/Manifest1
-rw-r--r--games-simulation/lincity-ng/lincity-ng-2.9_beta.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/games-simulation/lincity-ng/Manifest b/games-simulation/lincity-ng/Manifest
index 7460532650e7..b2974845809e 100644
--- a/games-simulation/lincity-ng/Manifest
+++ b/games-simulation/lincity-ng/Manifest
@@ -1 +1,2 @@
DIST lincity-ng-2.0.tar.bz2 39475719 BLAKE2B 39992e6a2ef78e53eea1b0e347c968f6828089b5267e6d62dac7405ea91b182335431b1718ef9892b649b1437751959deb9fa407dfd899fd1dfca55145d059f2 SHA512 d85cd398145d1591f8640458c076f2a0b55713c39ede28b67d99adc7b76d38f09b58cd2ec84d9acac11bbaa794f6d97f6200f54efcdd4286315e6b3133284c55
+DIST lincity-ng-2.9_beta.tar.gz 115799513 BLAKE2B 038c69172af9a62b35199823ef56200e170a8eafef2849bc6d8797bbc20ffa01656d05b1ba0725d4d33e217602f6695d3bdf2774b90b85c6e257e13e019bebcb SHA512 194b7389d7172b7987eda14cbbf2dd91aa503af36db9cf3bdf07ab6ae5e0068ac00988fec6068d65da6bdf14dee623bba57a58192e2a9659e741a7c9036e6d65
diff --git a/games-simulation/lincity-ng/lincity-ng-2.9_beta.ebuild b/games-simulation/lincity-ng/lincity-ng-2.9_beta.ebuild
new file mode 100644
index 000000000000..c71738c6f41b
--- /dev/null
+++ b/games-simulation/lincity-ng/lincity-ng-2.9_beta.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multiprocessing
+
+DESCRIPTION="City simulation game"
+HOMEPAGE="https://github.com/lincity-ng/lincity-ng"
+SRC_URI="https://github.com/lincity-ng/lincity-ng/archive/lincity-ng-${PV/_/-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 BitstreamVera CC-BY-SA-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-games/physfs
+ dev-libs/libxml2:2
+ media-libs/libsdl[sound,joystick,opengl,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf
+ sys-libs/zlib
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/ftjam
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}-${P/_/-}"
+
+src_prepare() {
+ default
+ sed -i "/COPYING COPYING-data.txt COPYING-fonts.txt CREDITS /d" \
+ Jamfile || die
+ ./autogen.sh || die
+}
+
+src_compile() {
+ jam -q -dx -j $(makeopts_jobs) || die "jam failed"
+}
+
+src_install() {
+ jam -sDESTDIR="${D}" \
+ -sappdocdir="${EPREFIX}/usr/share/doc/${PF}" \
+ -sapplicationsdir="${EPREFIX}/usr/share/applications" \
+ -spixmapsdir="${EPREFIX}/usr/share/pixmaps" \
+ install \
+ || die "jam install failed"
+}