summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-08-02 11:29:44 +0200
committerDavid Seifert <soap@gentoo.org>2021-08-02 11:29:44 +0200
commit016a96e218b9c5a0749ea3240ef1172af4b6036d (patch)
tree6de828f181dacdde6ffffdd73f2c93f67426ef52 /games-simulation/lincity
parentgames-simulation/lincity: EAPI6->8, fix prefix, add icon (diff)
downloadgentoo-016a96e218b9c5a0749ea3240ef1172af4b6036d.tar.gz
gentoo-016a96e218b9c5a0749ea3240ef1172af4b6036d.tar.bz2
gentoo-016a96e218b9c5a0749ea3240ef1172af4b6036d.zip
games-simulation/lincity: remove `append-cflags -std=gnu89`
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-simulation/lincity')
-rw-r--r--games-simulation/lincity/files/lincity-1.13.1-gcc-10.patch37
-rw-r--r--games-simulation/lincity/lincity-1.13.1-r2.ebuild4
2 files changed, 30 insertions, 11 deletions
diff --git a/games-simulation/lincity/files/lincity-1.13.1-gcc-10.patch b/games-simulation/lincity/files/lincity-1.13.1-gcc-10.patch
index 77f3a41dcf6c..a1d6ea0f2e70 100644
--- a/games-simulation/lincity/files/lincity-1.13.1-gcc-10.patch
+++ b/games-simulation/lincity/files/lincity-1.13.1-gcc-10.patch
@@ -1,7 +1,8 @@
+https://bugs.gentoo.org/570574
https://bugs.gentoo.org/706394
---- lincity-1.13.1/fileutil.c 2004-07-03 08:26:33.000000000 -0000
-+++ lincity-1.13.1/fileutil.c 2020-02-26 09:16:31.406614385 -0000
+--- a/fileutil.c
++++ b/fileutil.c
@@ -105,7 +105,7 @@
* ---------------------------------------------------------------------- */
char LIBDIR[LC_PATH_MAX];
@@ -11,8 +12,8 @@ https://bugs.gentoo.org/706394
int lc_save_dir_len;
static char *lc_temp_filename;
---- lincity-1.13.1/ldsvguts.c 2003-10-10 04:11:29.000000000 -0000
-+++ lincity-1.13.1/ldsvguts.c 2020-02-26 09:17:22.410992011 -0000
+--- a/ldsvguts.c
++++ b/ldsvguts.c
@@ -91,8 +91,6 @@
* Private Global Variables
* ---------------------------------------------------------------------- */
@@ -22,8 +23,8 @@ https://bugs.gentoo.org/706394
/* ---------------------------------------------------------------------- *
* Public functions
* ---------------------------------------------------------------------- */
---- lincity-1.13.1/main.c 2004-07-03 07:59:05.000000000 -0000
-+++ lincity-1.13.1/main.c 2020-02-26 09:17:04.222857373 -0000
+--- a/main.c
++++ b/main.c
@@ -96,9 +96,8 @@
#endif
#endif
@@ -35,8 +36,28 @@ https://bugs.gentoo.org/706394
#ifdef CS_PROFILE
int prof_countdown = PROFILE_COUNTDOWN;
---- lincity-1.13.1/screen.h 2004-06-22 13:24:19.000000000 -0000
-+++ lincity-1.13.1/screen.h 2020-02-26 09:14:31.473725606 -0000
+--- a/mouse.c
++++ b/mouse.c
+@@ -1094,7 +1094,7 @@
+ return 0;
+ }
+
+-inline int
++static inline int
+ mt_temp(int x, int y)
+ {
+ if (x < 0 || y < 0 || x >= WORLD_SIDE_LEN || y >= WORLD_SIDE_LEN)
+@@ -1128,7 +1128,7 @@
+ return 0;
+ }
+
+-inline int
++static inline int
+ mt_perm(int x, int y)
+ {
+ /* By now, it has already been mt_erase()'d */
+--- a/screen.h
++++ b/screen.h
@@ -20,7 +20,7 @@
extern unsigned char start_font2[4096];
extern unsigned char start_font3[4096];
diff --git a/games-simulation/lincity/lincity-1.13.1-r2.ebuild b/games-simulation/lincity/lincity-1.13.1-r2.ebuild
index f1cec025ba8f..c67386702def 100644
--- a/games-simulation/lincity/lincity-1.13.1-r2.ebuild
+++ b/games-simulation/lincity/lincity-1.13.1-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit desktop flag-o-matic
+inherit desktop
DESCRIPTION="City simulation game for X"
HOMEPAGE="http://lincity.sourceforge.net/"
@@ -30,8 +30,6 @@ PATCHES=(
)
src_configure() {
- append-cflags -std=gnu89 # build with gcc5 (bug #570574)
-
local econfargs=(
--with-gzip
--with-x