summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHendrik v. Raven <hendrik@consetetur.de>2018-04-25 12:56:37 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-09 14:26:35 +0200
commitd0cfe5ab38f5fdb283ed9148064490ca944597a9 (patch)
tree8efe02eae234c772aa8076036b3e45f3cd88703d /games-simulation/openrct2/openrct2-9999.ebuild
parentgames-simulation/openrct2: drop old (diff)
downloadgentoo-d0cfe5ab38f5fdb283ed9148064490ca944597a9.tar.gz
gentoo-d0cfe5ab38f5fdb283ed9148064490ca944597a9.tar.bz2
gentoo-d0cfe5ab38f5fdb283ed9148064490ca944597a9.zip
games-simulation/openrct2: update nightly
currently some tests fail due to data not beeing found Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-simulation/openrct2/openrct2-9999.ebuild')
-rw-r--r--games-simulation/openrct2/openrct2-9999.ebuild50
1 files changed, 33 insertions, 17 deletions
diff --git a/games-simulation/openrct2/openrct2-9999.ebuild b/games-simulation/openrct2/openrct2-9999.ebuild
index cc286b38589e..8a3a26a6c953 100644
--- a/games-simulation/openrct2/openrct2-9999.ebuild
+++ b/games-simulation/openrct2/openrct2-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit cmake-utils gnome2-utils
+inherit cmake-utils gnome2-utils xdg-utils
DESCRIPTION="An open source re-implementation of RollerCoaster Tycoon 2"
HOMEPAGE="https://openrct2.website/"
@@ -18,16 +18,16 @@ else
S="${WORKDIR}/OpenRCT2-${PV}"
fi
-TSV="0.1.0"
+TSV="0.1.2"
SRC_URI+=" https://github.com/OpenRCT2/title-sequences/releases/download/v${TSV}/title-sequence-v${TSV}.zip -> ${PN}-title-sequence-v${TSV}.zip "
+OBJV="1.0"
+SRC_URI+=" https://github.com/OpenRCT2/objects/releases/download/v${OBJV}/objects.zip -> ${PN}-objects-v${OBJV}.zip"
+
LICENSE="GPL-3"
SLOT="0"
IUSE="libressl +multiplayer opengl test truetype +twitch"
-# This is needed because of this bug: https://github.com/OpenRCT2/OpenRCT2/issues/5469
-REQUIRED_USE="multiplayer? ( twitch )"
-
RDEPEND="
>=dev-libs/jansson-2.5
>=dev-libs/libzip-1.0
@@ -47,15 +47,33 @@ RDEPEND="
twitch? ( net-misc/curl[ssl] )
"
DEPEND="${RDEPEND}
+ app-arch/unzip
test? ( dev-cpp/gtest )
"
-if [[ ${PV} == 9999 ]]; then
src_unpack() {
- default
- git-r3_src_unpack
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ else
+ unpack ${P}.tar.gz
+ fi
+
+ mkdir -p "${S}/data/title" || die
+ pushd "${S}/data/title" || die
+ unpack ${PN}-title-sequence-v${TSV}.zip
+ popd || die
+
+ mkdir -p "${S}/data/object" || die
+ pushd "${S}/data/object" || die
+ unpack ${PN}-objects-v${OBJV}.zip
+ popd || die
+}
+
+src_prepare() {
+ sed -i CMakeLists.txt -e 's/-Werror//' || die
+
+ cmake-utils_src_prepare
}
-fi
src_configure() {
local mycmakeargs=(
@@ -65,20 +83,14 @@ src_configure() {
-DDISABLE_TTF="$(usex !truetype)"
-DWITH_TESTS="$(usex test)"
-DDOWNLOAD_TITLE_SEQUENCES=OFF
- -DDISABLE_RCT2_TESTS=ON
+ -DDOWNLOAD_OBJECTS=OFF
-DSYSTEM_GTEST=ON
+ -DBUILD_SHARED_LIBS=ON
)
cmake-utils_src_configure
}
-src_install() {
- cmake-utils_src_install
-
- insinto /usr/share/openrct2/title
- doins "${WORKDIR}"/*.parkseq
-}
-
pkg_postinst() {
if [[ -z ${REPLACING_VERSIONS} ]]; then
ewarn ""
@@ -87,8 +99,12 @@ pkg_postinst() {
ewarn ""
fi
gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
}
pkg_postrm() {
gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
}