summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-18 23:07:08 +0200
committerDavid Seifert <soap@gentoo.org>2021-06-18 23:07:08 +0200
commitc2c24ad694d76c541d680eb671a34dd04838cbf4 (patch)
tree74b408cf6413a6668393927f1c16104efa1b724c /games-simulation/pmars-sdl
parentgames-simulation/pmars-sdl: modernise ebuild (diff)
downloadgentoo-c2c24ad694d76c541d680eb671a34dd04838cbf4.tar.gz
gentoo-c2c24ad694d76c541d680eb671a34dd04838cbf4.tar.bz2
gentoo-c2c24ad694d76c541d680eb671a34dd04838cbf4.zip
games-simulation/pmars-sdl: use pkg-config to find ncurses, x11
Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-simulation/pmars-sdl')
-rw-r--r--games-simulation/pmars-sdl/pmars-sdl-0.9.2e-r1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/games-simulation/pmars-sdl/pmars-sdl-0.9.2e-r1.ebuild b/games-simulation/pmars-sdl/pmars-sdl-0.9.2e-r1.ebuild
index ae564aa94c04..df1ca5fb51ee 100644
--- a/games-simulation/pmars-sdl/pmars-sdl-0.9.2e-r1.ebuild
+++ b/games-simulation/pmars-sdl/pmars-sdl-0.9.2e-r1.ebuild
@@ -25,6 +25,7 @@ RDEPEND="
!sdl? ( !X? ( sys-libs/ncurses:0= ) )
"
DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${P}-format.patch
@@ -46,15 +47,15 @@ src_compile() {
append-cflags $(sdl-config --cflags)
append-cppflags -DSDLGRAPHX
- LIB=$(sdl-config --libs)
+ LIB="$(sdl-config --libs)"
elif use X ; then
append-cppflags -DXWINGRAPHX
- LIB="-L${ESYSROOT}/usr/X11R6/lib -lX11"
+ LIB="$($(tc-getPKG_CONFIG) --libs x11)"
else
append-cppflags -DCURSESGRAPHX
- LIB="-lcurses -ltinfo"
+ LIB="$($(tc-getPKG_CONFIG) --libs ncurses)"
fi
cd src || die