summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-01 08:07:03 +0100
committerSam James <sam@gentoo.org>2023-08-01 08:09:01 +0100
commit00380b2bca5e2b862cfc468e1c1663b83d4780db (patch)
treec8ded7fd34986f8ba1ee48b78259bba900a314fb /games-simulation
parentgames-simulation/openttd: drop 13.0, 13.1 (diff)
downloadgentoo-00380b2bca5e2b862cfc468e1c1663b83d4780db.tar.gz
gentoo-00380b2bca5e2b862cfc468e1c1663b83d4780db.tar.bz2
gentoo-00380b2bca5e2b862cfc468e1c1663b83d4780db.zip
games-simulation/corsix-th: add 0.67_rc1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/corsix-th/Manifest1
-rw-r--r--games-simulation/corsix-th/corsix-th-0.67_rc1.ebuild84
-rw-r--r--games-simulation/corsix-th/metadata.xml1
3 files changed, 86 insertions, 0 deletions
diff --git a/games-simulation/corsix-th/Manifest b/games-simulation/corsix-th/Manifest
index b735a4821e26..a581758847ff 100644
--- a/games-simulation/corsix-th/Manifest
+++ b/games-simulation/corsix-th/Manifest
@@ -1 +1,2 @@
DIST corsix-th-0.66.tar.gz 4117046 BLAKE2B 7bceb0d5893849ba906ccd9516ecd52f0a1c54f3a91bff932c0db053f66e71a3d38dfdb55979cb9bb2047c7338b3badbb32defa216a9867fb7166f4ca14bfa75 SHA512 a5cea74e7754132a7edbe188c63c08eb40ba8a8bbef6dc7441e41c5f46e96cacaa077d00bead4f8b3af3b8e07eadb4cfd08b1fb147e1397e2f9aa02642d29105
+DIST corsix-th-0.67_rc1.tar.gz 4127427 BLAKE2B c6f7c40dac0780b0c00de0ec7432b86aa4c09a0ffb0eaf87e58abee7b934b2c9fc9e151b86a7edf588ca1a65d42b27eeb9f63ec64f1a5250e2b7e1f60d2d3226 SHA512 cb104ba81a1c70bcdf49f0659bd544fc003b8a89dd8bbfa504676086da35b4817702b02933b4fcf239f6ac784c091d28867db246a8f6242952f3abdfdb959690
diff --git a/games-simulation/corsix-th/corsix-th-0.67_rc1.ebuild b/games-simulation/corsix-th/corsix-th-0.67_rc1.ebuild
new file mode 100644
index 000000000000..fb20bf9d939b
--- /dev/null
+++ b/games-simulation/corsix-th/corsix-th-0.67_rc1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} )
+
+inherit cmake lua-single xdg
+
+MY_PN="CorsixTH"
+MY_PV="${PV/_/-}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Open source clone of Theme Hospital"
+HOMEPAGE="https://corsixth.com"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+if [[ ${PV} != *_beta* && ${PV} != *_rc* ]] ; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+IUSE="doc +midi +sound tools +truetype +videos"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="${LUA_DEPS}
+ $(lua_gen_cond_dep '
+ >=dev-lua/luafilesystem-1.5[${LUA_USEDEP}]
+ >=dev-lua/lpeg-0.9[${LUA_USEDEP}]
+ >=dev-lua/luasocket-3.0_rc1-r4[${LUA_USEDEP}]
+ ')
+ media-libs/libsdl2[opengl,video]
+ sound? ( media-libs/sdl2-mixer[midi?] )
+ truetype? ( >=media-libs/freetype-2.5.3:2 )
+ videos? ( >=media-video/ffmpeg-2.2.3:0= )
+"
+
+DEPEND="${RDEPEND}"
+
+# Technically, build-time generation of documentation could use any version
+# of Lua (or to be precise: if in src_configure cmake has been told to use
+# LuaJIT documentation generation looks for LuaJIT, otherwise any
+# dev-lang/lua slot will do; see the first few lines of the bundled file
+# CMake/GenerateDoc.cmake for details) - but since dev-lang/lua conflicts
+# with the other slots of same, try to keep the deptree sane until we get
+# rid of unslotted Lua.
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen[dot]
+ ${LUA_DEPS}
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.66-cmake_lua_detection.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DLUA_VERSION=$(lua_get_version)
+ -DBUILD_TOOLS=$(usex tools)
+ -DWITH_AUDIO=$(usex sound)
+ -DWITH_FREETYPE2=$(usex truetype)
+ -DWITH_MOVIES=$(usex videos)
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_src_compile doc
+}
+
+src_install() {
+ cmake_src_install
+ dodoc changelog.txt CONTRIBUTING.md
+
+ docinto html
+ use doc && dodoc -r "${BUILD_DIR}"/doc/*
+}
diff --git a/games-simulation/corsix-th/metadata.xml b/games-simulation/corsix-th/metadata.xml
index 3dac5f6d9022..500a549db1fe 100644
--- a/games-simulation/corsix-th/metadata.xml
+++ b/games-simulation/corsix-th/metadata.xml
@@ -13,6 +13,7 @@
</longdescription>
<use>
<flag name="midi">Adds support for background MIDI music via SDL_mixer</flag>
+ <flag name="tools">Build tools for decoding RNC files</flag>
</use>
<upstream>
<remote-id type="github">CorsixTH/CorsixTH</remote-id>