summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-11-16 21:37:02 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-11-16 21:37:02 +0100
commit1d19803e7db93e18bc890f10079177319dc6b563 (patch)
tree871397fd7ffa6ca24ec616804e23b57d620ef61d /games-simulation
parentapp-emulation/pcem: switch WX from 3.0-gtk3 to 3.2-gtk3 (diff)
downloadgentoo-1d19803e7db93e18bc890f10079177319dc6b563.tar.gz
gentoo-1d19803e7db93e18bc890f10079177319dc6b563.tar.bz2
gentoo-1d19803e7db93e18bc890f10079177319dc6b563.zip
games-simulation/openrct2: fix compilation with gcc14
Closes: https://bugs.gentoo.org/917016 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/openrct2/files/openrct2-0.4.6-gcc14.patch30
-rw-r--r--games-simulation/openrct2/openrct2-0.4.6.ebuild1
2 files changed, 31 insertions, 0 deletions
diff --git a/games-simulation/openrct2/files/openrct2-0.4.6-gcc14.patch b/games-simulation/openrct2/files/openrct2-0.4.6-gcc14.patch
new file mode 100644
index 000000000000..2c2c00fff5e7
--- /dev/null
+++ b/games-simulation/openrct2/files/openrct2-0.4.6-gcc14.patch
@@ -0,0 +1,30 @@
+From 11c46987aed7f8ef941140a171d55abc8cd8d0d5 Mon Sep 17 00:00:00 2001
+From: Kostadin <kocelfc@tutanota.com>
+Date: Thu, 16 Nov 2023 22:26:05 +0200
+Subject: [PATCH] Add #include <algorithm> to fix building with gcc 14 (#20981)
+
+With gcc 14 some C++ Standard Library headers have been changed to no
+longer include other headers that were used internally by the library.
+In OpenRCT2's case it is the <algorithm> header.
+
+Downstream Gentoo bug: https://bugs.gentoo.org/917016
+
+GCC 14 porting guide: https://gcc.gnu.org/gcc-14/porting_to.html#header-dep-changes
+
+Signed-off-by: Kostadin Shishmanov <kocelfc@tutanota.com>
+---
+ src/openrct2/core/FileWatcher.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/openrct2/core/FileWatcher.cpp b/src/openrct2/core/FileWatcher.cpp
+index 439be15859ed..3ce0309c8cc8 100644
+--- a/src/openrct2/core/FileWatcher.cpp
++++ b/src/openrct2/core/FileWatcher.cpp
+@@ -7,6 +7,7 @@
+ * OpenRCT2 is licensed under the GNU General Public License version 3.
+ *****************************************************************************/
+
++#include <algorithm>
+ #include <array>
+ #include <cstdio>
+ #include <stdexcept>
diff --git a/games-simulation/openrct2/openrct2-0.4.6.ebuild b/games-simulation/openrct2/openrct2-0.4.6.ebuild
index 64107568e416..3049ac705a1b 100644
--- a/games-simulation/openrct2/openrct2-0.4.6.ebuild
+++ b/games-simulation/openrct2/openrct2-0.4.6.ebuild
@@ -73,6 +73,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-0.4.0-include-additional-paths.patch"
"${FILESDIR}/${PN}-0.4.1-gtest-1.10.patch"
+ "${FILESDIR}/${PN}-0.4.6-gcc14.patch"
)
src_unpack() {