summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2019-11-19 10:47:53 +0100
committerJames Le Cuirot <chewi@gentoo.org>2019-11-19 23:27:38 +0000
commit32068cf7204c8310cc646c916b2a0128becb79fd (patch)
tree4ac10f438a15758892c1b60657ef20e34b8f360f /games-simulation
parentgames-simulation/micropolis: Move sys-devel/bison into BDEPEND (diff)
downloadgentoo-32068cf7204c8310cc646c916b2a0128becb79fd.tar.gz
gentoo-32068cf7204c8310cc646c916b2a0128becb79fd.tar.bz2
gentoo-32068cf7204c8310cc646c916b2a0128becb79fd.zip
games-simulation/micropolis: fix eclass usage, don't call gcc directly
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/13703 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/micropolis/micropolis-1.0-r2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/games-simulation/micropolis/micropolis-1.0-r2.ebuild b/games-simulation/micropolis/micropolis-1.0-r2.ebuild
index 185b1d35b1f0..c329f78b0817 100644
--- a/games-simulation/micropolis/micropolis-1.0-r2.ebuild
+++ b/games-simulation/micropolis/micropolis-1.0-r2.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit eutils
+
+inherit desktop eutils toolchain-funcs
DESCRIPTION="Free version of the well-known city building simulation"
HOMEPAGE="http://www.donhopkins.com/home/micropolis/"
@@ -43,7 +44,7 @@ src_prepare() {
}
src_compile() {
- emake -C src LDFLAGS="${LDFLAGS}"
+ emake -C src LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)"
}
src_install() {