summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-07-16 11:07:34 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-07-16 11:08:10 +0200
commit411d6e9248ea22a72d1291969c17fd32a2de527f (patch)
tree0f2e5060b7782408b54dd5d5a4c7e71ad1590d11 /games-simulation
parentdev-php/pecl-gnupg: Allow gnupg 2. (diff)
downloadgentoo-411d6e9248ea22a72d1291969c17fd32a2de527f.tar.gz
gentoo-411d6e9248ea22a72d1291969c17fd32a2de527f.tar.bz2
gentoo-411d6e9248ea22a72d1291969c17fd32a2de527f.zip
games-simulation/openttd: Bump to version 1.8.0. Removed old.
Package-Manager: Portage-2.3.42, Repoman-2.3.9
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/openttd/Manifest2
-rw-r--r--games-simulation/openttd/files/openttd-1.8.0-icu61.patch45
-rw-r--r--games-simulation/openttd/openttd-1.8.0.ebuild (renamed from games-simulation/openttd/openttd-1.8.0_rc1.ebuild)22
3 files changed, 58 insertions, 11 deletions
diff --git a/games-simulation/openttd/Manifest b/games-simulation/openttd/Manifest
index 5bcc9a0a188d..0830de1214cf 100644
--- a/games-simulation/openttd/Manifest
+++ b/games-simulation/openttd/Manifest
@@ -1,3 +1,3 @@
DIST openttd-1.7.1-source.tar.gz 10090311 BLAKE2B 339171cd2895398ee1fedcfd24d1126fbc060b6d4530b267310b3f220448f8e6469a726e71e9882bea117585ea7b9f7271205f576ee2b26de6dec079f57f1620 SHA512 4a0d2ee424374b50fe0d089b86ff16b5de3159848a38143ca6745e349b6126567f1e4beda9afe2e6bc21ffffce1166acf719d3f5c95703a14c1379f8857e83d3
DIST openttd-1.7.2-source.tar.gz 10097175 BLAKE2B a027b6ca6d3116dc3e6ad6ae43965682107268e367032418200cf1c1e16c5b5dad39c275ea57d923f17564d80cceb0e9909dc5aaf7ee230242f0ce0f46f06b1a SHA512 44d25061c42cb9c81baa67a40ff31a6681dcbb121c61db74c5179a31f189919471a82b7fd3f79c2cdeef02af5b47ec35fdbdc7feed74ca2360c028869fe772e8
-DIST openttd-1.8.0-RC1-source.tar.xz 6520976 BLAKE2B 17d34378ba3aa7a9def9f3ff764c42b890a646946211184660c3af9e252b9a809d481ccdd31421442efd9c7fac86f5c9c6091987070d53d1c913d3ef680f413c SHA512 aff6833934ce875320bdba3410be15a53fc8c233e7efe60628158636eed3b179fea5c8e9f8af2181c16bc173c409eab93477f2165d448100d048959bf63ba3d2
+DIST openttd-1.8.0-source.tar.xz 6521016 BLAKE2B b3a608fd21d21f861af6eba235c028a59f071ab4698cfdcdd499b6ea7ece853679b064935368d95330414a24ac90aaa3c426afc12a2e135d5b0a48170879b807 SHA512 a2d61b3c94a550c8f3a581127df8c3459b1ddff5ba924942c468cbc70e88e0bf4405cecb68a91243b544ead64f215aa8d489a07b38dce507ae7d59e8ec155d7a
diff --git a/games-simulation/openttd/files/openttd-1.8.0-icu61.patch b/games-simulation/openttd/files/openttd-1.8.0-icu61.patch
new file mode 100644
index 000000000000..e4143d82f679
--- /dev/null
+++ b/games-simulation/openttd/files/openttd-1.8.0-icu61.patch
@@ -0,0 +1,45 @@
+From 19076c24c1f3baf2a22d1fa832d5688216cf54a3 Mon Sep 17 00:00:00 2001
+From: Charles Pigott <charlespigott@googlemail.com>
+Date: Sun, 8 Apr 2018 01:06:18 +0100
+Subject: [PATCH] Fix #6690: Compilation with ICU 61
+
+---
+ src/language.h | 2 +-
+ src/strings.cpp | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/language.h b/src/language.h
+index d33ba81892..ec241dbd8c 100644
+--- a/src/language.h
++++ b/src/language.h
+@@ -105,7 +105,7 @@ extern LanguageList _languages;
+ extern const LanguageMetadata *_current_language;
+
+ #ifdef WITH_ICU_SORT
+-extern Collator *_current_collator;
++extern icu::Collator *_current_collator;
+ #endif /* WITH_ICU_SORT */
+
+ bool ReadLanguagePack(const LanguageMetadata *lang);
+diff --git a/src/strings.cpp b/src/strings.cpp
+index 1c539d9343..fd7420259a 100644
+--- a/src/strings.cpp
++++ b/src/strings.cpp
+@@ -52,7 +52,7 @@ const LanguageMetadata *_current_language = NULL; ///< The currently loaded lang
+ TextDirection _current_text_dir; ///< Text direction of the currently selected language.
+
+ #ifdef WITH_ICU_SORT
+-Collator *_current_collator = NULL; ///< Collator for the language currently in use.
++icu::Collator *_current_collator = NULL; ///< Collator for the language currently in use.
+ #endif /* WITH_ICU_SORT */
+
+ static uint64 _global_string_params_data[20]; ///< Global array of string parameters. To access, use #SetDParam.
+@@ -1795,7 +1795,7 @@ bool ReadLanguagePack(const LanguageMetadata *lang)
+
+ /* Create a collator instance for our current locale. */
+ UErrorCode status = U_ZERO_ERROR;
+- _current_collator = Collator::createInstance(Locale(_current_language->isocode), status);
++ _current_collator = icu::Collator::createInstance(icu::Locale(_current_language->isocode), status);
+ /* Sort number substrings by their numerical value. */
+ if (_current_collator != NULL) _current_collator->setAttribute(UCOL_NUMERIC_COLLATION, UCOL_ON, status);
+ /* Avoid using the collator if it is not correctly set. */
diff --git a/games-simulation/openttd/openttd-1.8.0_rc1.ebuild b/games-simulation/openttd/openttd-1.8.0.ebuild
index 6eca8d5fbef6..2d97c8bf0810 100644
--- a/games-simulation/openttd/openttd-1.8.0_rc1.ebuild
+++ b/games-simulation/openttd/openttd-1.8.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils gnome2-utils
+inherit gnome2-utils
MY_PV="${PV/_rc/-RC}"
MY_P="${PN}-${MY_PV}"
@@ -51,14 +51,20 @@ S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}"/${PN}-1.6.0-cflags.patch
+ "${FILESDIR}"/${PN}-1.8.0-icu61.patch
)
src_configure() {
- local myopts=()
+ local myopts=(
+ $(use_with iconv)
+ $(use_with png)
+ $(use_with cpu_flags_x86_sse sse)
+ $(use_with lzo liblzo2)
+ )
# there is an allegro interface available as well as sdl, but
# the configure for it looks broken so the sdl interface is
# always built instead.
- local myopts+=( --without-allegro )
+ myopts+=( --without-allegro )
# libtimidity not needed except for some embedded platform
# nevertheless, it will be automagically linked if it is
@@ -70,8 +76,8 @@ src_configure() {
if use dedicated ; then
myopts+=( --enable-dedicated )
else
- use aplaymidi && myopts+=( --with-midi='/usr/bin/aplaymidi' )
myopts+=(
+ $(usex aplaymidi '--with-midi=/usr/bin/aplaymidi' '')
$(use_with truetype freetype)
$(use_with icu)
--with-sdl
@@ -92,10 +98,6 @@ src_configure() {
--install-dir="${D}" \
--menu-group="Game;Simulation;" \
${myopts[@]} \
- $(use_with iconv) \
- $(use_with png) \
- $(use_with cpu_flags_x86_sse sse) \
- $(use_with lzo liblzo2) \
|| die
}
@@ -107,9 +109,9 @@ src_install() {
default
if use dedicated ; then
newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN}
- rm -rf "${ED}"/usr/share/{applications,icons,pixmaps}
+ rm -rf "${ED%/}"/usr/share/{applications,icons,pixmaps}
fi
- rm -f "${ED}"/usr/share/doc/${PF}/COPYING
+ rm -f "${ED%/}"/usr/share/doc/${PF}/COPYING
}
pkg_preinst() {